Broken links to images in XHTML output

This forum is for all Flare issues related to PDF, eBook, Microsoft Word, Adobe FrameMaker, XPS, and XHTML book targets.

Broken links to images in XHTML output

Postby lindabab on Thu Apr 20, 2017 2:10 am

Hi everyone,

this is probably a really simple question but I am new to Madcap Flare and have little to no knowledge about HTML.
I got a project where I have a PDF and an XHTML target. When publishing the output the PDF looks great, but I encountered some problems with the XHTML output.
When opened in the output folder, the XHTML looks good, but as soon as I copy the file to another location (other server/ desktop etc) the links to the images are broken.
The code to the images look like this:

<div class="imagesFloatRight">
<p style="page-break-after: avoid;">
<img src="../Resources/Images/Detail 3D model.png" style="max-width: 290px;max-height: auto;" />
</p>
<p class="ImageCaption">Detail 3D model of a fore peak section</p>
</div>

Does anyone have a clue why this is happening and how I could fix this? Thanks a lot in advance!
lindabab
Jr. Propeller Head
 
Posts: 2
Joined: Tue Apr 18, 2017 2:31 am

Re: Broken links to images in XHTML output

Postby SKamprowski on Thu Apr 20, 2017 4:30 am

Hi lindabab,

you'd better copy the complete content folder that has been generated by Flare, or try to use Flares publish function.
Kind regards,
Sabine Kamprowski
DocToHelp MVP
SKamprowski
Sr. Propeller Head
 
Posts: 184
Joined: Fri Feb 13, 2015 8:25 am
Location: Germany

Re: Broken links to images in XHTML output

Postby lindabab on Thu Apr 20, 2017 4:42 am

SKamprowski wrote:Hi lindabab,

you'd better copy the complete content folder that has been generated by Flare, or try to use Flares publish function.


Hi SKamrowski,

yes I tried copying the complete folder and indeed it works that way as the links will be preserved.
The basic idea would be actually that the whole content is available through the single .htm file, even if it's sent in an email - so independently from it's output folder. Is there a way to do that?

I do publish the target by right clicking and selecting "Publish 'filename (Clean XHTML)'" from the drop-down menu. Is there any other way that would fix my problem, or maybe changing some target properties?
lindabab
Jr. Propeller Head
 
Posts: 2
Joined: Tue Apr 18, 2017 2:31 am

Re: Broken links to images in XHTML output

Postby Nita Beck on Thu Apr 20, 2017 9:27 am

lindabab wrote:The basic idea would be actually that the whole content is available through the single .htm file, even if it's sent in an email - so independently from it's output folder. Is there a way to do that?

No, as the image itself is not embedded into the topic; rather, there is a link to the image in the topic's code. That's how HTML works.

Why are you trying to send an .htm file via email? If, by chance, you are trying to send a topic to someone for their review, you could preview the topic in Flare and then print to PDF from the preview window, and then send the PDF via email. Or you could open the topic in your output folder and then print to PDF from there.
Nita
Image
Content Strategist / Information Architect / Flare Consultant: http://beck-communications.com
Manager, Rochester Flare User Group: http://www.facebook.com/RochesterFlareUserGroup
Nita Beck
Senior Propellus Maximus
 
Posts: 2837
Joined: Thu Feb 02, 2006 9:57 am
Location: Pittsford, NY


Return to Printed Documentation Targets

Who is online

Users browsing this forum: No registered users and 2 guests

cron