Build Word target - Error 10086 Build failed

This forum is for all Flare issues related to PDF, eBook, Microsoft Word, Adobe FrameMaker, XPS, and XHTML book targets.

Build Word target - Error 10086 Build failed

Postby mkenn on Thu Jun 06, 2019 3:24 am

I've been building my Word target without any problems until the last few days when I'm now getting a Build Failed right at the very end.

Build log error shows - 10086 Build failed: Generation of output can not be completed. Command failed.

I've watched the status as it's been going through and it gets right to the very end after trying to embed images, then bails.

I've opened the XML file and it's incomplete, only 24 pages are in there (although the Navigator on the left lists all of the topics...). The output Word folder is empty.

It's been building fine until recently, nothing really has changed other than just generally adding stuff. It builds ok to PDF, but we want the Word outputs as our primary output, mainly for our external translation company, but there are other internal reasons why we want Word not just PDF.

It's not a massive doc, but not small either - 300 pages. Is there a limit on the size of a doc you can build? Could it be a memory issue?

Any thoughts or help would be very much appreciated.

Many thanks.
mkenn
Jr. Propeller Head
 
Posts: 5
Joined: Mon Jan 21, 2019 2:47 am

Re: Build Word target - Error 10086 Build failed

Postby ChoccieMuffin on Thu Jun 06, 2019 8:50 am

Nothing concrete to suggest, other than my default first things to try. Quit Flare and delete \Output and \Analyzer folders. The underlying database sometimes gets its knickers in a twist and this forces Flare to regenerate it. Hope your problem magically goes away with that one.
Started as a newbie with Flare 6.1, now using Flare 2019r1.
Report bugs at http://www.madcapsoftware.com/bugs/submit.aspx.
Request features at https://www.madcapsoftware.com/feedback ... quest.aspx
ChoccieMuffin
Senior Propellus Maximus
 
Posts: 2025
Joined: Wed Apr 14, 2010 8:01 am
Location: Surrey, UK

Re: Build Word target - Error 10086 Build failed

Postby Psider on Thu Jun 06, 2019 5:18 pm

It's possible a new topic caused the temporary build path to exceed 255 characters. Theoretically it'd be one of the files just before the build fails, so you could start by checking those.

See here for a longer discussion.
viewtopic.php?f=9&t=30270&hilit=10086+build+failed#p131673
Psider
Propellus Maximus
 
Posts: 550
Joined: Wed Jul 06, 2011 1:32 am

Re: Build Word target - Error 10086 Build failed

Postby mkenn on Fri Jun 07, 2019 7:24 am

Thank you both. I tried both of your suggestions, but sadly no joy (I was really hoping it was as simple as the path being too long).
It seems to create all of the temporary files, including the folder of images. Then bails at the point of embedding the images into the Word doc.

I've tried taking topics out, rebuilding and one-by-one adding topics in and rebuilding. Limited success. It works, I get excited, add another few topics, rebuild, then it bails. But not always on the same topic, and when I introduce the topic that I think might be crashing it, it builds fine but then falls over at a different point. So it doesn't seem to be a particular topic crashing it, nor any particular image.

There are a fair few images in here, but all fairly small .png. Could it be a memory thing...?

If you have any other suggestions that would be great.
mkenn
Jr. Propeller Head
 
Posts: 5
Joined: Mon Jan 21, 2019 2:47 am

Re: Build Word target - Error 10086 Build failed

Postby wclass on Tue Jun 11, 2019 8:54 pm

Does it build ok without embedding the images? Might be worth a try.

In the "olden" days, we'd create Word docs like that and then use a macro in Word to embed the images outside of Flare.
That macro can be found in the old knowledgebase.
https://kb.madcapsoftware.com/Content/Flare/Outputs/Printed_Documentation/Word/OUTPW1010F_-_Linking_Images_In_word.htm

You can turn off the embedding in the Target - look in the Advanced tab for the check box.
Margaret Hassall - Melbourne
wclass
Propellus Maximus
 
Posts: 1214
Joined: Mon Feb 27, 2006 5:56 am
Location: Melbourne, Australia

Re: Build Word target - Error 10086 Build failed

Postby mkenn on Wed Jun 12, 2019 12:31 am

Thanks wclass, I thought you'd hit on the solution.
But sadly no. I tried, it still failed...

I also tried getting it to generate to multiple documents, bu that doesn't seem to be working either. I've given a colleague a copy of the project so that he can try on his machine, thinking that if it worked for him then it's something we can narrow it down to. But it also fails for him., although not always in the same place as where it seems to fail for me...

It builds fine to PDF, so I think I might have to just do that then convert from PDF to Word for now.

Thanks everyone for your help.
mkenn
Jr. Propeller Head
 
Posts: 5
Joined: Mon Jan 21, 2019 2:47 am

Re: Build Word target - Error 10086 Build failed

Postby mkenn on Wed Jun 12, 2019 8:07 am

***RESOLVED***

By trial and error I've managed to resolve this. It seemed to be down to a couple of tables in a couple of topics that the build process didn't like (no idea why!). I re-created the tables and now it builds fine to Word.

Many thanks for your help and suggestions.
mkenn
Jr. Propeller Head
 
Posts: 5
Joined: Mon Jan 21, 2019 2:47 am


Return to Printed Documentation Targets

Who is online

Users browsing this forum: No registered users and 1 guest