Error: "Build Failed: The directory is not empty"

This forum is for all Flare issues related to PDF, eBook, Microsoft Word, Adobe FrameMaker, XPS, and XHTML book targets.

Error: "Build Failed: The directory is not empty"

Postby ccardimon on Fri Apr 24, 2015 11:28 am

What should I do if I encounter the error "Build Failed: The directory is not empty" when trying to build my PDF output?
Craig

Lost in Disturbia
ccardimon
Propellus Maximus
 
Posts: 1571
Joined: Fri Jan 11, 2008 1:30 pm
Location: Horsham, Pennsylvania

Re: Error: "Build Failed: The directory is not empty"

Postby dorcutt on Fri Apr 24, 2015 12:29 pm

I usually encounter this error when I've been manually opening a file in my Output folder. For some reason, this seems to sometimes stop Flare from auto-clearing the output folder, even if I have since closed the file. I just close anything relevant that I have open, delete the contents of that target's Output folder, and run the build again.

Not sure if you're having the same issue though.
-Dan, Propellerhead-in-training
dorcutt
Sr. Propeller Head
 
Posts: 234
Joined: Thu May 15, 2014 12:16 pm

Re: Error: "Build Failed: The directory is not empty"

Postby ccardimon on Fri Apr 24, 2015 12:32 pm

Thank you.
Craig

Lost in Disturbia
ccardimon
Propellus Maximus
 
Posts: 1571
Joined: Fri Jan 11, 2008 1:30 pm
Location: Horsham, Pennsylvania

Re: Error: "Build Failed: The directory is not empty"

Postby BrianBXYPRO on Thu May 12, 2016 4:21 pm

I've been getting this error a lot today but I've found that if I close Flare and then reopen it the problem goes away.

Brian
Flare ( :flare: ) v12, Windows 10
BrianBXYPRO
Propeller Head
 
Posts: 23
Joined: Tue May 03, 2016 12:04 pm
Location: Simi Valley, CA

Re: Error: "Build Failed: The directory is not empty"

Postby Nita Beck on Fri May 13, 2016 4:40 am

Instead of restarting Flare, maybe just clean the project (which deletes everything in the Output folder) and then try to build the PDF. So that's Project > Clean Project.
Nita
Image
Content Strategist / Information Architect / Flare Consultant: http://beck-communications.com
Manager, Rochester Flare User Group: http://www.facebook.com/RochesterFlareUserGroup
Nita Beck
Senior Propellus Maximus
 
Posts: 3290
Joined: Thu Feb 02, 2006 9:57 am
Location: Pittsford, NY

Re: Error: "Build Failed: The directory is not empty"

Postby BrianBXYPRO on Fri May 13, 2016 11:28 am

Hmmm. I'm starting to think it's a Flare 12 issue because it only happened a handful of times with Flare 11 but on Flare 12 it's a daily occurrence for me. Also, it only happens on my print outputs and never the online ones.

Brian
Flare ( :flare: ) v12, Windows 10
BrianBXYPRO
Propeller Head
 
Posts: 23
Joined: Tue May 03, 2016 12:04 pm
Location: Simi Valley, CA

Re: Error: "Build Failed: The directory is not empty"

Postby netwrk219 on Tue Dec 06, 2016 11:28 am

I've found that if you have the app "AdobeCollabSynch.exe" running in Taskmaster, that this is the reason for the error. It keeps a copy of the document built and displayed in Acrobat, so that it isn't really deleted. I couldn't find a way to properly delete it and since I heavily use Creative Cloud apps for work, I decided to simply rename the file by taking one character out. Now, I can find it and use it if it is ever necessary and since I did this the error hasn't returned.

Hope this helps a future Flare traveler.
Keith S.

“Most of us find our own voices only after we’ve sounded like a lot of other people.” –Neil Gaiman
User avatar
netwrk219
Propeller Head
 
Posts: 26
Joined: Mon Nov 28, 2016 8:58 am
Location: Fort Mill, SC

Re: Error: "Build Failed: The directory is not empty"

Postby Dee Vincent-Day on Thu Dec 08, 2016 9:02 am

I get this happening a fair bit. I just start the build again and it runs ok. It usually happens when I have been viewing an output then closed it and clicked Rebuild Target.
Dee Vincent-Day
Technical Author
Piksel

liberating viewing | Piksel.com

http://www.piksel.com
Dee Vincent-Day
Propeller Head
 
Posts: 62
Joined: Mon Jan 04, 2016 7:39 am
Location: York, North Yorkshire, England

Re: Error: "Build Failed: The directory is not empty"

Postby bwait on Wed Jan 25, 2017 7:21 pm

Hi folks

We are running Flare 2017 and are seeing this bug a lot. I found that if I use Windows to delete the Output folder entirely, it fixes the problem, albeit temporarily. I have tried the Clean Project command too, but it cannot delete everything for some reason. It appears that the same files that Clean Project fails to delete are those blocking the build, which makes sense. MadCap should fix this bug.
bwait
Propeller Head
 
Posts: 10
Joined: Wed Aug 01, 2012 5:21 pm

Re: Error: "Build Failed: The directory is not empty"

Postby netwrk219 on Thu Jan 26, 2017 6:05 am

bwait wrote:Hi folks

We are running Flare 2017 and are seeing this bug a lot. I found that if I use Windows to delete the Output folder entirely, it fixes the problem, albeit temporarily. I have tried the Clean Project command too, but it cannot delete everything for some reason. It appears that the same files that Clean Project fails to delete are those blocking the build, which makes sense. MadCap should fix this bug.


I turned off AdobeCC Auto sync and it helped with this issue quite a bit. For some reason though, stopping the sync capability to AdobeCC only works for a bit, then it turns itself back on again, possibly through Acrobat. One person in this thread mentioned that it wasn't a Madcap issue but an Adobe one and they were absolutely right. The issue stems from Adobe not releasing the file completely after editing is complete. I have added a link below to a screenshot of the Adobe CC screen where the option is located.
https://drive.google.com/a/colossalarts.com/file/d/0B3kYbMmvGKpGM3BMeG9ocUpGX3c/view?usp=sharing
You do not have the required permissions to view the files attached to this post.
Keith S.

“Most of us find our own voices only after we’ve sounded like a lot of other people.” –Neil Gaiman
User avatar
netwrk219
Propeller Head
 
Posts: 26
Joined: Mon Nov 28, 2016 8:58 am
Location: Fort Mill, SC

Re: Error: "Build Failed: The directory is not empty"

Postby rkotraba on Fri Nov 09, 2018 10:30 am

Thanks for posting this fix--this worked to solve the issue for me.

netwrk219 wrote:
bwait wrote:Hi folks

We are running Flare 2017 and are seeing this bug a lot. I found that if I use Windows to delete the Output folder entirely, it fixes the problem, albeit temporarily. I have tried the Clean Project command too, but it cannot delete everything for some reason. It appears that the same files that Clean Project fails to delete are those blocking the build, which makes sense. MadCap should fix this bug.


I turned off AdobeCC Auto sync and it helped with this issue quite a bit. For some reason though, stopping the sync capability to AdobeCC only works for a bit, then it turns itself back on again, possibly through Acrobat. One person in this thread mentioned that it wasn't a Madcap issue but an Adobe one and they were absolutely right. The issue stems from Adobe not releasing the file completely after editing is complete. I have added a link below to a screenshot of the Adobe CC screen where the option is located.
https://drive.google.com/a/colossalarts.com/file/d/0B3kYbMmvGKpGM3BMeG9ocUpGX3c/view?usp=sharing
rkotraba
Jr. Propeller Head
 
Posts: 6
Joined: Mon Jan 22, 2018 8:51 am

Re: Error: "Build Failed: The directory is not empty"

Postby ceriwilliams on Thu Apr 11, 2019 2:44 am

netwrk219 wrote:I've found that if you have the app "AdobeCollabSynch.exe" running in Taskmaster, that this is the reason for the error. It keeps a copy of the document built and displayed in Acrobat, so that it isn't really deleted.


Ending this task also worked for me. Thanks for sharing!
ceriwilliams
Jr. Propeller Head
 
Posts: 4
Joined: Tue May 22, 2018 3:01 am


Return to Printed Documentation Targets

Who is online

Users browsing this forum: No registered users and 2 guests