PDF Writer: Failed to convert to PDF font: Arial Unicode MS.

This forum is for all Flare issues related to PDF, eBook, Microsoft Word, Adobe FrameMaker, XPS, and XHTML book targets.

PDF Writer: Failed to convert to PDF font: Arial Unicode MS.

Postby chuck_agari on Thu Apr 18, 2019 11:43 am

I get this "warning" ("PDF Writer: Failed to convert to PDF font: Arial Unicode MS. Using default font: Helvetica.") every time I build a PDF. I see it explicitly when I build from a topic file, and I discovered it is indeed an error when I build a full target PDF. A search for this error found a "solution" that said to "install [the font] for all users." But (a) That font is not on my system anywhere, and (b) a search for "Arial Unicode MS" in the source code of the entire project gave zero results.

Nothing seems to look wrong in the output. So what's Flare trying to do and how do I fix it?
chuck_agari
Sr. Propeller Head
 
Posts: 192
Joined: Wed May 30, 2018 2:40 pm

Re: PDF Writer: Failed to convert to PDF font: Arial Unicode

Postby nielsf on Wed Oct 30, 2019 5:42 am

Sorry, no solution for you - just saying that I have that exact problem, too...
-----
Flaring in Copenhagen, Denmark
nielsf
Propeller Head
 
Posts: 86
Joined: Mon Feb 02, 2015 5:44 am
Location: Copenhagen, Denmark

Re: PDF Writer: Failed to convert to PDF font: Arial Unicode

Postby ChoccieMuffin on Wed Oct 30, 2019 8:00 am

You should both raise a bug and see if you get an answer from the Madcap techies. You are unlikely to get an answer to "what's Flare trying to do and how do I fix it?" on peer forums...
Started as a newbie with Flare 6.1, now using Flare 2019r1.
Report bugs at http://www.madcapsoftware.com/bugs/submit.aspx.
Request features at https://www.madcapsoftware.com/feedback ... quest.aspx
ChoccieMuffin
Senior Propellus Maximus
 
Posts: 2147
Joined: Wed Apr 14, 2010 8:01 am
Location: Surrey, UK

Re: PDF Writer: Failed to convert to PDF font: Arial Unicode

Postby robdocsmith on Wed Oct 30, 2019 3:15 pm

Do you have fonts explicitly specified for the body element? There may be a carry over from Flare defaults that causes the issue. Perhaps I'm just a control freak and like to make sure my body pages and all sub elements are defined fonts-wise.

Can you check in any output in the Temporary folder (Output/name/Temporary/path_to_build) and search for the missing font name or the substituted Helvetica font name? That might point to where the font is being used. This is where Flare puts the interim htm build files before compiling into a PDF.

Cheers,
Rob
robdocsmith
Propeller Head
 
Posts: 31
Joined: Thu May 24, 2018 3:11 pm


Return to Printed Documentation Targets

Who is online

Users browsing this forum: No registered users and 2 guests