Can't build Word target (error 10086, parsing EntityName)

This forum is for all Flare issues related to PDF, eBook, Microsoft Word, Adobe FrameMaker, XPS, and XHTML book targets.

Can't build Word target (error 10086, parsing EntityName)

Postby rgatwood on Mon Mar 29, 2021 12:57 pm

Hello! I'm using Flare 2019 on Windows 10 Enterprise. My coworkers and I have been trying to build a certain Word target, and only one of us (the person who created the project) is able to do it.

When I click Build Primary and select the project I want, the build conks out halfway through with a 10052 warning message, two 101 errors, and finally the following 10086 error:

Build failed: An error occurred while parsing EntityName. Line 1, position 86.

(The two 101 errors are identical to the above except they don't say "Build failed".)

I looked in a few files in Text Editor and found nothing weird-looking in the first lines (no ampersands or TMs, for example).
rgatwood
Jr. Propeller Head
 
Posts: 3
Joined: Mon Mar 29, 2021 9:23 am

Re: Can't build Word target (error 10086, parsing EntityName

Postby SteveS on Mon Mar 29, 2021 2:03 pm

Where are you building to?

If the person who created the project has pointed to a local directory, or a network drive they created, do you have the appropriate network privileges to access and create files in that location?
Image
Steve
Life's too short for bad coffee, bad chocolate, and bad red wine.
SteveS
Senior Propellus Maximus
 
Posts: 2027
Joined: Tue Mar 07, 2006 5:06 pm
Location: Adelaide, far side of the world ( 34°56'0.78\"S 138°46'44.28\"E).

Re: Can't build Word target (error 10086, parsing EntityName

Postby rgatwood on Tue Mar 30, 2021 8:58 am

Thanks for replying. I'm building to a folder on my C:\ drive where I have permissions. The path looks like \Output\rgatwood\(parent folder)\(target folder)
rgatwood
Jr. Propeller Head
 
Posts: 3
Joined: Mon Mar 29, 2021 9:23 am

Re: Can't build Word target (error 10086, parsing EntityName

Postby rgatwood on Wed Mar 31, 2021 9:36 am

Update: We found what was causing the problem! Per my coworker's suggestion, I created a brand-new target, topic, and TOC, and tried to build that. It failed with the same error, but this time it indicated something wrong in Stylesheets in the document modal.css.

In modal.css, there were lines saying this:

/*<meta sourceDocument="C:\Users\(my coworker's username)\Desktop\(the name of a .docx file)" />*/

This must have come from importing Word docs into Flare.

When we edited modal.css to remove these lines, I was able to build the Word doc. Now we just need to fix a few Word doc problems.
rgatwood
Jr. Propeller Head
 
Posts: 3
Joined: Mon Mar 29, 2021 9:23 am


Return to Printed Documentation Targets

Who is online

Users browsing this forum: No registered users and 12 guests

cron