Topic Body Proxy not visible in XML Editor

This forum is for all Flare issues related to PDF, eBook, Microsoft Word, Adobe FrameMaker, XPS, and XHTML book targets.

Topic Body Proxy not visible in XML Editor

Postby Paul Griffiths on Wed Jun 04, 2008 3:31 am

Has any one else seen (or rather not seen) this? I can add a body proxy to a master page, the bodyProxy tag is visible in the Text Editor, but the tag does not appear at all in the XML Editor, either within the master page itself or in the left-side tag bars. Consequently, I can't right-click and choose Edit Body Proxy, as there is nothing to right-click!
Paul Griffiths
Sr. Propeller Head
 
Posts: 248
Joined: Wed Apr 18, 2007 2:25 am
Location: Nottingham, UK

Re: Topic Body Proxy not visible in XML Editor

Postby LTinker68 on Wed Jun 04, 2008 9:43 am

When you insert the body proxy in the masterpage, are you on a blank <p> tag line, or did you inadvertently try to insert it into the breadcrumbs proxy or one of the other proxies?

And if you're using source control, do you have the file checked out and have permission to edit it?
Image

Lisa
Eagles may soar, but weasels aren't sucked into jet engines.
Warning! Loose nut behind the keyboard.
LTinker68
Master Propellus Maximus
 
Posts: 7245
Joined: Thu Feb 16, 2006 9:38 pm

Re: Topic Body Proxy not visible in XML Editor

Postby Paul Griffiths on Fri Jun 06, 2008 8:27 am

Update: They have mysteriously appeared.
Paul Griffiths
Sr. Propeller Head
 
Posts: 248
Joined: Wed Apr 18, 2007 2:25 am
Location: Nottingham, UK

Re: Topic Body Proxy not visible in XML Editor

Postby KevinDAmery on Fri Jun 06, 2008 9:25 am

Make sure you have block display turned on. This is controlled with an icon above the XML editor.
Until next time....
Image
Kevin Amery
Certified MAD for Flare
KevinDAmery
Propellus Maximus
 
Posts: 1985
Joined: Tue Jan 23, 2007 8:18 am
Location: Darn, I knew I was around here somewhere...

Re: Topic Body Proxy not visible in XML Editor

Postby Paul Griffiths on Fri Jun 06, 2008 2:04 pm

Well, this is embarassing. I just needed to enable Show Markers. But, note, until you do this the MadCap:bodyProxy tag doesn't appear in the left-side block display either. So that's what confused me.
Paul Griffiths
Sr. Propeller Head
 
Posts: 248
Joined: Wed Apr 18, 2007 2:25 am
Location: Nottingham, UK

Re: Topic Body Proxy not visible in XML Editor

Postby mattf on Tue Jun 17, 2008 3:27 pm

Paul,
You're not alone in this. I have been frustrated about this, too. I didn't know about enabling Show Markers... I'll try that. Glad I stopped by. Thanks!
Matt F
You learn something new every day if you're not careful.
mattf
Sr. Propeller Head
 
Posts: 276
Joined: Thu Feb 09, 2006 5:35 pm
Location: Next to the window


Return to Printed Documentation Targets

Who is online

Users browsing this forum: No registered users and 4 guests