Problem with xref {para}

This forum is for all Flare issues related to PDF, eBook, Microsoft Word, Adobe FrameMaker, XPS, and XHTML book targets.

Problem with xref {para}

Postby NickC on Fri Jun 20, 2008 2:50 am

I'm converting from Flare (3.1) to Word 2003 and am stuck because all the xrefs which use the property mc-format {para} don't work. The {page} property is active in the Word output (but incidently does not work when I generate PDF...).

Thanks in advance for your wisdom and experience!
NickC
Propeller Head
 
Posts: 39
Joined: Fri Aug 10, 2007 5:21 am
Location: Angers, France

Re: Problem with xref {para}

Postby forfear on Wed Jul 09, 2008 7:38 am

NickC wrote:The {page} property is active in the Word output (but incidently does not work when I generate PDF...).

Thanks in advance for your wisdom and experience!


Hi!
In what way does it not work? What does the PDF output of a sample cross-ref look like. What does the output look like in Word.

In PDF, all crossrefs and any hyperlinks are not clickable. Its just a standard static PDF file.
Only Acrobat can do that.
If you submit your bug feedback request here, the more likely it'll get fixed or included in a future release
Open Utilities PageLayout Resizer for Flare/Blaze | Batch builder
forfear
Propellus Maximus
 
Posts: 766
Joined: Sat Feb 16, 2008 3:37 am
Location: Jungle Jingles

Re: Problem with xref {para}

Postby Dave Lee on Thu Jul 10, 2008 4:06 am

forfear wrote:In PDF, all crossrefs and any hyperlinks are not clickable. Its just a standard static PDF file.
Only Acrobat can do that.


I can get xref links working in Word and PDF.

First off, the xref {para} format doesn't create a hyperlink in the Word output (I think it should really), but using the {page} format works fine - i.e. page numbers are clickable.

I also got these xref links working fine in the PDF, by creating the PDF using Word 2007 and the PDF add-in.

I was unable to test it by making the PDF with Acrobat. From memory, if you print the Word doc to the Acrobat PDF printer, then the links won't work - they will only work if you make the PDF using the Acrobat PDF maker (i.e. use the toolbar icon).
Unfortunately, I'm not able to test this on my PC as PDF maker doesn't work (it goes missing) when you use Acrobat 6 and Word 2007 together.
Dave Lee
Master Propellus Maximus
 
Posts: 5749
Joined: Mon Mar 05, 2007 8:33 am
Location: UK

Re: Problem with xref {para}

Postby DurtyMat on Thu Jul 10, 2008 1:45 pm

I am having the same issue with my xref style in print outputs.
Flare: I bought it ... so that means I can break it, right?
User avatar
DurtyMat
Sr. Propeller Head
 
Posts: 224
Joined: Wed Aug 22, 2007 8:09 am
Location: ClrH2o, Fl

Re: Problem with xref {para}

Postby NickC on Thu Jul 17, 2008 7:24 am

Dave Lee wrote:I can get xref links working in Word and PDF.

First off, the xref {para} format doesn't create a hyperlink in the Word output (I think it should really), but using the {page} format works fine - i.e. page numbers are clickable.

I also got these xref links working fine in the PDF, by creating the PDF using Word 2007 and the PDF add-in.


Dave, do I understand you just got the {page} link to work or, did you also get the xref {para} link to be a real clickable link?

I agree that the xref {para} link should be a real hyperlink in Word (and therefore PDF).

On a related point, the mc-format seems pretty buggy. The formats when applied don't always filter through to Word (2003) output. This is true for bolded text. I also tried putting double then straight quotes around the para text or trying to change the text color. Everything previews well but no dice when generated ...
NickC
Propeller Head
 
Posts: 39
Joined: Fri Aug 10, 2007 5:21 am
Location: Angers, France

Re: Problem with xref {para}

Postby Dave Lee on Fri Jul 18, 2008 3:57 am

NickC wrote:Dave, do I understand you just got the {page} link to work or, did you also get the xref {para} link to be a real clickable link?


Yep, only the {page} style generated a hyperlink in the word doc, the {para} style doesn't work.
Dave Lee
Master Propellus Maximus
 
Posts: 5749
Joined: Mon Mar 05, 2007 8:33 am
Location: UK

Re: Problem with xref {para}

Postby kristil on Tue Jul 22, 2008 2:32 pm

I emailed tech support about {para} not making links in Word targets. A feature request was added for it.
kristil
Propeller Head
 
Posts: 83
Joined: Mon Dec 17, 2007 1:44 pm
Location: Chicago, IL


Return to Printed Documentation Targets

Who is online

Users browsing this forum: darrenpalmer and 2 guests