Problem with embedded GIST in TriPane

This forum is for all Flare related Tips and Tricks.
Have a tip or trick you use while working in Flare? Share it here.

Problem with embedded GIST in TriPane

Postby ghillerson on Thu Apr 20, 2017 10:07 am

I have a large number of topics that include embedded GIST scripts. (If you don't know: GISTs are code snippets stored as GitHub repos, which you can link into pages). They are linked into my topics with the JS scripts that GIT generates when you save a GIST; for example:
Code: Select all
<div class="gistWrapperWide">
      <script src="https://gist.github.com/ghillerson/0e325d1a3ccf711c84d8f657c81ad40d.js"></script>
</div>


These have been working just fine in our top-nav (HTML5) version. We have just switched to a tripane version of the docs. The GISTS now display fine, as they've always done; HOWEVER, in the tripane version, when a user clicks the 'View Raw' button in the displayed GIST, the Flare topic container goes blank, and the only recovery is to use the browser's 'Back' button. This did not happen in the top-nav version. My assumption is that this has to do with how Flare puts the topic in a frame. AN example is here: https://docstest.splicemachine.com/#Developers/Connecting/JDBCJava.html. Scroll down and click "View Raw' under the displayed code.

If you right-click "View Raw" and display it in a separate tab/window, all is fine.

I could really use some help figuring out a way to get my GIST displays working in the tripane nav model; this is a major problem for us right now.

Thanks in advance,
Gary
ghillerson
Propeller Head
 
Posts: 85
Joined: Wed Mar 05, 2014 10:22 pm
Location: Near Santa Cruz, CA

Return to Tips and Tricks

Who is online

Users browsing this forum: No registered users and 1 guest