Publish to FTP trouble, Access is denied (code=550)

This forum is for all Flare related Tips and Tricks.
Have a tip or trick you use while working in Flare? Share it here.

Publish to FTP trouble, Access is denied (code=550)

Postby sds on Mon Oct 15, 2018 12:42 pm

I'm actually posting a solution that worked for me since I was unable to find what I was looking for on the forums. I give all credit to the IT Gods in this office.

We wanted our help published on a web server, which can be launched directly from our program. They are using IIS to run the FTP server, using basic authentication, SSL not required.

I created the FTP Destination file, and linked it in my HTML5 Target as the Publish Destination. In the FTP Destination file, I selected FTP as the Type, gave the proper Host Name and Port, and selected Passive as the mode. The Directory field is where we ran into problems:

Every time I published, I would get variations of 'Publish failed'. I tried checking the .mclog file, and couldn't find anything valuable. No broken links in my project, etc., and when I tested everything on FileZilla, it checked out.

Our directory field was root, so in the Directory field in the FTP Destination file, we tried using /, we tried using ./, we tried using .\, and we tried using \. I would end up with a 'Publish failed' every time. Eventually, we figured out that a sub-folder had to be added to the web server (i.e., [softwarename]Help). We used that same sub-folder name in the Directory field of the FTP Destination file, and the publish was suddenly completed without error. They rearranged some stuff on their end so our program would honor that, and successfully launch the live-updated help. Basically, if the Directory field is root, MadCap wouldn't connect; a sub-folder had to be added.

In the humble opinion of the IT people here, this is something MadCap should change. On a forum thread elsewhere, I saw someone mention that you just have to add ./, but that definitely did not work.

Just wanted to put it out there in case anyone else is having the same issue. Any other tips or tricks for using FTP sites to publish help are welcome.
sds
Propeller Head
 
Posts: 12
Joined: Tue Jun 26, 2018 11:29 am

Re: Publish to FTP trouble, Access is denied (code=550)

Postby ChoccieMuffin on Tue Oct 16, 2018 2:05 am

Well done to your IT peeps for finding and resolving the problem.

You're right, this is something that should be sorted. So I suggest you add a bug report (see my signature), let them know you've got a workaround, and get them to raise a feature request - initially to add that information into the Flare docs and more permanently to fix it.
Started as a newbie with Flare 6.1, now using Flare 2019r1.
Report bugs at http://www.madcapsoftware.com/bugs/submit.aspx.
Request features at https://www.madcapsoftware.com/feedback ... quest.aspx
ChoccieMuffin
Senior Propellus Maximus
 
Posts: 2147
Joined: Wed Apr 14, 2010 8:01 am
Location: Surrey, UK


Return to Tips and Tricks

Who is online

Users browsing this forum: No registered users and 3 guests