Page 1 of 1

Git Issue

PostPosted: Thu Sep 12, 2019 8:49 am
by dkaflowitz
Have been resolving massive problems involving Flare and Git for days and have it down to a select few. I am not knowledgeable about Git at all so I have had a lot of help from developers.

I have a file named Content12.s3db in MyProjects/<projectname>/Analyzer; it won't commit and it seems to be preventing my pushes to the remote repository. Has anyone else seen this and does anyone have any insight as to why this is?

I also have a .gitignore file at the MrProjects level that should make this moot because /Analyzer is listed in it. It seems to have no effect.

Thank you.

Re: Git Issue

PostPosted: Fri Sep 13, 2019 1:54 pm
by Daniel Ferguson
Was this file previously committed? Is it already tracked in your repo?

Re: Git Issue

PostPosted: Tue Oct 08, 2019 9:54 am
by amo7een
Hi All,

I'm also having this issue. I publish two help sites, one internal and one external. I've figured out that if I Clean Project in the Project ribbon before I publish, then my external (customer-facing site) publishes with current content and a correct TOC/navigation menu (whew). However, the internal site doesn't update no matter what I do. The most recent output folders and last pushed files to source control (Git) appear correct. When I View Primary, it builds correctly. I have a ticket in with support, but reaching out here, too.

FYI: I'm a tech writer--the first time I heard the term "output folder" was last Friday. Git was only a vague concept to me until I took this position seven months ago. I do have a lot of dev support here, though, so I'm trying to gather info to take to my team so they know where to start.

Thanks to those who keep this forum up, it's saved me more than once!