Page 1 of 1

Non-interactive generation failed

PostPosted: Fri Oct 20, 2017 11:39 am
by pdavidson
Received the following error when building a movie: Non-interactive generation failed: unable to initialize script

It seems to have occurred during the "Generating single file output..." process. When I attempted to view the mp4 file, the audio works but there are no images. HELP?!?!?

Re: Non-interactive generation failed

PostPosted: Fri Jul 06, 2018 8:36 am
by athenarosa
I struggled with this problem for a day and a half before opening a help request with MadCap support. My project & the ffmpeg encoder where already in local directories, but when I checked the folder properties and followed the recommended steps, it resolved the problem for me. I don't know why the properties were all of a sudden a problem (this same project was working fine for me just a month ago). I guess something must have changed with system updates.

Anyway, here's the info that tech support sent. Hope it keeps other folks from losing valuable time!

*******************

On your end, are you storing the project on a local drive or network drive? It is recommended always to keep your working copy on the local drive.
Is the ffmpeg encoder stored in a path where you have access, on the local drive?
Is the project stored on a path where you have full read write access and permissions?
You can try to see if the following steps grant you access when you perform them on the Mimic project folder, output folder, and ffmpeg folder:

1. Navigate to the folder that contains these files in Windows Explorer
2. Right-click on the folder and select Properties
3. Clear the check box for "Read-only"
4. In the window that opens, select "Apply changes to this folder, subfolders and files" and click OK.

It is normal for the check box to appear filled with a box to indicate indeterminate state. Clearing the box will ensure the files are not read-only.


Verify that your domain user account has the necessary permissions:

1. Right-click on the folder and select Properties
2. Go to the Security tab
3. Select your name in the list
4. Verify that you have Full Control permission.

If your name does not appear in this list, try adding it:

1. Click "Add..."
2. Input your domain user name. This appears below your name in the info page you can open from Start > (click on your user icon) > Change account settings
3. Click Check Names and the field should populate with your name
4. Click OK
5. Verify you have full control