Cannot create HTML5 build after importing RoboHelp project

This forum is for all Flare issues related to getting started and installing the application.

Cannot create HTML5 build after importing RoboHelp project

Postby Dennetti on Tue Apr 09, 2019 3:44 am

HI. I am testing Flare using an imported RoboHelp project. In RoboHelp, many of these topics are not included in the output, and are not in the the TOC we use. They have broken links, which is not a problem in RoboHelp as they are never included in the output. However, the build is failing in Flare because of these broken links. Can I exclude this topics in Flare, so they are never considered in the build process? Any advice for a newbie would be appreciated.
Dennetti
Propeller Head
 
Posts: 24
Joined: Fri Sep 21, 2018 1:42 am

Re: Cannot create HTML5 build after importing RoboHelp proje

Postby Dave Lee on Tue Apr 09, 2019 4:13 am

A broken link might cause build warnings, but I don't think broken links should cause build failures (i.e. build errors) that stop the build from working.

You can exclude topics in a few ways:
* A quick method is to use the target setting Advanced > Exclude content not linked directly or indirectly from the target. This will exclude and content that isn't linked from anywhere, so might work for you.
* A more reliable/robust method is to set a condition on the topics you don't want to include, and exclude that condition in the target.
Dave Lee
Master Propellus Maximus
 
Posts: 5498
Joined: Mon Mar 05, 2007 8:33 am
Location: UK

Re: Cannot create HTML5 build after importing RoboHelp proje

Postby Dennetti on Tue Apr 09, 2019 5:54 am

Thanks. I already had " Exclude content not linked directly or indirectly from the target" set, but no luck. I tried excluding unwanted content by setting a condition, but the build still fails just after trying to process a topic that is not in the TOC. I get the following error: "Build failed: Unexpected end of file while parsing CDATA has occurred."
Dennetti
Propeller Head
 
Posts: 24
Joined: Fri Sep 21, 2018 1:42 am

Re: Cannot create HTML5 build after importing RoboHelp proje

Postby devjoe on Thu Apr 11, 2019 7:35 am

The suggested solutions are probably not going to work with topics that have invalid XML. When you ran the import, you should have gotten warnings about any topics like this which Flare couldn't parse, and so imported without any processing. You'll either need to fix the topics so the XML is valid, or remove them from the Content folder.

The root cause is you had invalid code in the topics in the RoboHelp project you imported - a problem I experienced also a few years ago, on a couple dozen out of tens of thousands of imported topics over many projects.
devjoe
Sr. Propeller Head
 
Posts: 280
Joined: Thu Jan 23, 2014 1:43 pm

Re: Cannot create HTML5 build after importing RoboHelp proje

Postby Dennetti on Fri Apr 12, 2019 4:03 am

Thanks very much. I removed a handful of topics from the output, and it now builds OK.
Dennetti
Propeller Head
 
Posts: 24
Joined: Fri Sep 21, 2018 1:42 am


Return to Getting Started and Installation Issues

Who is online

Users browsing this forum: No registered users and 2 guests

cron