Flare 9.1 Madbuild error codes

This forum is for all Flare issues related to getting started and installing the application.

Flare 9.1 Madbuild error codes

Postby Bonnie Kern on Tue May 28, 2013 10:36 am

Flare 9.1 adds several error codes, including:

3 = Build completed with compiler warnings

which breaks automatic builds.

(http://webhelp.madcapsoftware.com/flare ... ersion.htm)

Can we suppress error code 3 or others?

Thanks,
Bonnie
Bonnie Kern
Propeller Head
 
Posts: 29
Joined: Mon Mar 16, 2009 3:54 pm

Re: Flare 9.1 Madbuild error codes

Postby scrapy39 on Thu May 30, 2013 11:07 am

There is no way to suppress the errors. I have submitted a request to have that added to future releases.

The real issue here is that when you have compiler warnings (now error code 3), complex build scripts will fail due to warnings... In our case, we had to roll back to version 9.0 in order to make our builds work once again. If I were building the code with batch scripts, there would be no issue as the batch file would return success even when there are failures. I am using msbuild to get our help docs into our product (since it is a Microsoft project). Throwing an error code on something that we have in our source code but no longer include with the product: "Generating alias file: Topic excluded from output:". This used to just show in the build log as a compiler warning, however with the changes in 9.1, it bubbles an error code up and causes the build to fail. The madbuild.exe outputs are generated successfully, but since the error code 3 is bubbled up, the msbuild script fails and does not run anything after the madbuild step. If there were a way to include a way to suppress the errors from the madbuild.exe, we would be very happy.

Here is an example of how msbuild.exe does it: msbuild.exe projectfile.proj -target /p:NoWarn=3... This will cause msbuild to not fail out if msbuild returns an error code 3. To my knowledge, the script cannot however suppress an error coming from outside of MSBUILD such as is now the case with madbuild.exe.

I have rolled back to using the 9.0 version of madbuild.exe and everything is working and I won't be able to upgrade until this issue is resolved or I find a better workaround.
Jade Nielsen
Build Engineer
vmware
scrapy39
Jr. Propeller Head
 
Posts: 1
Joined: Tue May 28, 2013 12:21 pm

Re: Flare 9.1 Madbuild error codes

Postby Bonnie Kern on Thu May 30, 2013 1:02 pm

Thanks Jade for getting the auto builds up and running again! =)

Bonnie
Bonnie Kern
Propeller Head
 
Posts: 29
Joined: Mon Mar 16, 2009 3:54 pm

Re: Flare 9.1 Madbuild error codes

Postby RichardTroiano on Wed Jun 05, 2013 10:50 am

I have rolled back to using the 9.0 version of madbuild.exe and everything is working and I won't be able to upgrade until this issue is resolved or I find a better workaround.


How exactly did you manage to roll back the 9.1 install to 9.0? I was surprised when I went to Control Panel\Programs\Programs and Features and saw that Flare is listed at verison 9.0 in the Uninstall or change a program panel

Image

However, I am running Flare 9.1

Image

By 'rolling back' do you mean simply uninstalling and reinstalling? The machine in question that I need to 'roll back' flare is a production machine and I would rather not have to do a full uninstall and reinstall just to remove a stupid patch.

I am having the same sort of issues as others with 9.1, but all of my webhelp builds are now failing with an Error Code 7 , which I guess means I am 'Missing linked file'. I have a great idea, why not TELL ME WHAT LINKED FILE IS MISSING SO I CAN FIX IT? I am running 15 different webhelp outputs, and the source files contain well over 100,000 HTML files, 10,000 images, lots of various scripts and other bits of code to make the whole thing work. Telling me that I am missing a linked file is like pointing at the sky and saying "find this star, it's a white point of light". Not very helpful. Obviously madbuild.exe knows what file it can't find considering it encountered an error code while processing it - why not tell the end user what file it can't find? I cannot be the only person who thinks this might be a logical thing to do.
RichardTroiano
Jr. Propeller Head
 
Posts: 5
Joined: Tue Jan 31, 2012 10:12 am

Re: Flare 9.1 Madbuild error codes

Postby FlareLearner on Thu Sep 16, 2021 6:53 am

Has there been any update on this, please? We are also looking into how to suppress or ignore the madbuild exit codes 2,3, and 7 so that our script can run successfully.
FlareLearner
Jr. Propeller Head
 
Posts: 1
Joined: Mon Sep 28, 2020 6:53 am

Re: Flare 9.1 Madbuild error codes

Postby Nita Beck on Fri Sep 17, 2021 7:59 am

FlareLearner wrote:Has there been any update on this, please? We are also looking into how to suppress or ignore the madbuild exit codes 2,3, and 7 so that our script can run successfully.

Welcome to the forums! :)

That said, you might get better info by contacting MadCap tech support, rather than posting in these peer-to-peer forums, particularly to an old thread. (Watch, someone here will prove me wrong and offer you some solid advice... ;) ).
Nita
Image
Content Strategist / Information Architect / Flare Consultant: http://beck-communications.com
Manager, Rochester Flare User Group: http://www.facebook.com/RochesterFlareUserGroup
Nita Beck
Senior Propellus Maximus
 
Posts: 3463
Joined: Thu Feb 02, 2006 9:57 am
Location: Pittsford, NY


Return to Getting Started and Installation Issues

Who is online

Users browsing this forum: No registered users and 1 guest

cron