"The surrogate pair (0xD83D, 0xD83D) is invalid..." Word imp

This forum is for all Flare issues related to importing files or projects.

"The surrogate pair (0xD83D, 0xD83D) is invalid..." Word imp

Postby Jeong on Wed Feb 05, 2020 12:19 am

When importing a particular Word doc in a particular project, I am seeing the following error:

Screen1.png


Anyone seen this before? The Options > Build > Byte Order Marker option makes no difference.
I've tried creating a new, empty project and trying to import the same Word doc, and there's no problem in a new project (but I kinda need it in this project)
(Support request sent)
You do not have the required permissions to view the files attached to this post.
Jeong
Propeller Head
 
Posts: 22
Joined: Wed Jan 01, 2020 12:05 am

Re: "The surrogate pair (0xD83D, 0xD83D) is invalid..." Word

Postby Jeong on Tue Feb 11, 2020 11:10 pm

In case anyone else comes across this - found the solution today. This is related to a bug in Flare (reported) where one cannot insert the link character into a document: Character's decimal code: 🔗
Looks like:
link.png


The import bug is the reverse. If you have that character present in a document you are trying to import, Flare will fail to import the file and report the "surrogate pair... is invalid" error. Solution is to delete all instances of that link character in your source document, then re-add the document for import.
You do not have the required permissions to view the files attached to this post.
Jeong
Propeller Head
 
Posts: 22
Joined: Wed Jan 01, 2020 12:05 am

Re: "The surrogate pair (0xD83D, 0xD83D) is invalid..." Word

Postby Chicago_HPT on Wed Feb 12, 2020 9:31 am

Thanks for sharing the root cause and the solution/work-around.
Chicago_HPT
Propeller Head
 
Posts: 77
Joined: Sun Feb 03, 2013 6:01 pm


Return to Importing

Who is online

Users browsing this forum: Google [Bot] and 2 guests