Source files going missing after reimport

This forum is for all Flare issues related to importing files or projects.

Source files going missing after reimport

Postby purrplexity on Thu Sep 05, 2019 6:37 am

For reasons too tedious to get into, my department currently has around 100 projects that are linked together as HTML file sets and this causes a bunch of problems so I am working on rebuilding using Flare Project Imports until we get source control and can allow multiple authors to be in the same project.

I have run into a fairly horrifying issue and I am not sure if it is a break or something I am doing wrong. When I reimport projects (say I have updated information in the source project and want it to be in the child project, you know, like you do) the original files keep GOING MISSING in the source. They are still in the child project. They still show as linked in the child project. I still get warnings telling me if they are updated in the source project they could get overwritten. But they are just GONE from the source.

I thought that imports just created a link?? Why would being imported elsewhere cause my files to go missing?

We have been using a "template" project for YEARS and it is imported into other projects as a Flare Project Import and there have been no issues at all with the source files going missing... until last week. Thank goodness I have backups but this is not sustainable and does NOT seem to be functioning properly. Is there some sort of setting that says "oh hey, rip this from the source project because that's what I meant by import" that I should be leaving unchecked???

Help!
purrplexity
Jr. Propeller Head
 
Posts: 8
Joined: Thu Jun 22, 2017 1:00 pm

Re: Source files going missing after reimport

Postby GDonn on Tue Sep 17, 2019 2:32 pm

I am having a similar issue that appears to be triggered when importing files from a global template. I thought it was because I was storing my global template and projects on OneDrive. I have learned that that is not a good practice because of versioning issues with cloud apps. So, I moved everything temporarily to our server and put my templates on my C drive. Well, it happened again and having read that there can be issues working between a server and local, I got an external HD and started using that to store my working projects. It happened again just a short time ago, one of my single source image files disappeared but this time, not from the template but the project.

Am I assuming that the best way to work is to have everything, my projects and all of my imported templates, on my local drive? I seriously do not have that kind of space and on two occasions in the past I maxed out the space on the server (I also do all of my own graphics so I keep all of my related work together in master project folders that include all of my Illustrator and Photoshop files and background research notes and files in sub-folders).

This issue of losing template files began to happen towards the end of July. Prior to that, for all the years that I've been using Flare and this same template I have not experienced anything like this. I'm just glad I have backups of my backups because I would seriously lose my mind since this tends to happen when I have short notice deadlines. By the way, I am basically a one person operation supporting a grossly understaffed engineering department at a very small business unit of a very large global corporation.
GDonn
Propeller Head
 
Posts: 15
Joined: Mon Jul 21, 2014 1:52 pm

Re: Source files going missing after reimport

Postby ChoccieMuffin on Wed Sep 18, 2019 6:38 am

I think you both need to contact Tech Support, as there's something obviously going squiffy for you. Do let us know what they say.
Started as a newbie with Flare 6.1, now using Flare 2019r1.
Report bugs at http://www.madcapsoftware.com/bugs/submit.aspx.
Request features at https://www.madcapsoftware.com/feedback ... quest.aspx
ChoccieMuffin
Senior Propellus Maximus
 
Posts: 2105
Joined: Wed Apr 14, 2010 8:01 am
Location: Surrey, UK

Re: Source files going missing after reimport

Postby GDonn on Thu Oct 03, 2019 1:17 pm

So, I heeded all the advice I've seen in other threads to work strictly on a local drive simply because strange things happen when Flare projects are stored elsewhere like servers, cloud storage and even an external USB HD. I moved all of my template files to my desktop and also created a desktop folder to hold just my individual product specific Flare projects as sub-folders. So far, I have not had any issues with file loss after importing a global template with specified file imports. I'm knocking on wood that this will be foolproof going forward since my workload for new product documentation is about to hit the roof.

One other practice I've gone back to is making sure I tick the box on the General tab of the Target editor that says," Disable auto-sync of all import files." I've gone back to manually re-importing templates and if there have been any changes to the global template since the last re-import I will delete the old import entirely and create a new global import. It only takes a minute and I don't experience the random error messages I get if I don't. Hopefully then next version won't be so buggy.
GDonn
Propeller Head
 
Posts: 15
Joined: Mon Jul 21, 2014 1:52 pm

Re: Source files going missing after reimport

Postby ChoccieMuffin on Fri Oct 04, 2019 3:14 am

Flare really DOES NOT LIKE working on a network drive, so now that you've moved everything to your local drive, you should find things work as they ought to.

I strongly suggest you get some kind of source control in place, to avoid the chance of losing your stuff. If your engineering department uses some kind of source control it shouldn't be too much effort on their part to set up a repository for you as well.
Started as a newbie with Flare 6.1, now using Flare 2019r1.
Report bugs at http://www.madcapsoftware.com/bugs/submit.aspx.
Request features at https://www.madcapsoftware.com/feedback ... quest.aspx
ChoccieMuffin
Senior Propellus Maximus
 
Posts: 2105
Joined: Wed Apr 14, 2010 8:01 am
Location: Surrey, UK


Return to Importing

Who is online

Users browsing this forum: No registered users and 1 guest