inexplicable inline styles

This forum is for all Flare issues related to styles, stylesheets and XML.

inexplicable inline styles

Postby kirinawust on Tue Mar 12, 2019 2:44 am

Hi Forum,
I am using Flare 2018 r2. My css includes styles like p.ResultatAntwort
Using these styles, Flare includes all their definitions inline, so I'm getting:
<p class="ResultatAntwort" MadCap:autonum="&lt;span style=&quot;font-family: 'Wingdings';&quot; class=&quot;mcFormatFamily&quot;&gt;&lt;span style=&quot;font-size: 12pt;&quot; class=&quot;mcFormatSize&quot;&gt;ð&lt;/span&gt;&lt;/span&gt; &#160;" >Text </p>

instead of
<p class="ResultatAntwort" >Text </p>

This behaviour has not been there in Flare 9, 10 and 11.
Is there an option switch where I can get rid of these inline styles?

Any hint is much appreciated.
Irina
kirinawust
Propeller Head
 
Posts: 12
Joined: Tue Nov 05, 2013 5:08 am

Re: inexplicable inline styles

Postby ChoccieMuffin on Tue Mar 12, 2019 4:08 am

Just checking - what does your code look like BEFORE you apply the style?
Started as a newbie with Flare 6.1, now using Flare 2018.
Report bugs at http://www.madcapsoftware.com/bugs/submit.aspx.
Request features at https://www.madcapsoftware.com/feedback ... quest.aspx
ChoccieMuffin
Propellus Maximus
 
Posts: 1935
Joined: Wed Apr 14, 2010 8:01 am

Re: inexplicable inline styles

Postby kirinawust on Tue Mar 12, 2019 8:16 am

original code, for example:
<p class="Fliesstext">Text</p>

apply style:
<p class="Anweisung">Text</p>

save file, close file, reopen file:
<p class="Anweisung" MadCap:autonum="&lt;span style=&quot;font-family: 'Arial';&quot; class=&quot;mcFormatFamily&quot;&gt;&lt;span style=&quot;font-size: 11pt;&quot; class=&quot;mcFormatSize&quot;&gt;► &lt;/span&gt;&lt;/span&gt;">Text</p>
kirinawust
Propeller Head
 
Posts: 12
Joined: Tue Nov 05, 2013 5:08 am

Re: inexplicable inline styles

Postby ChoccieMuffin on Tue Mar 12, 2019 8:58 am

I suspect it's something to do with how your autonumbering is applied. Do you have a particular autonum style for what you're using? I have a similar thing going on when I insert a cross-reference:

"For details see <MadCap:xref href="Running_on_another_machine.htm"><span style="color: Blue;" class="mcFormatColor">Running on another machine</span></MadCap:xref>."

It's not elegant, but I suspect it's "as designed", but you could try raising a bug for it, in case it's not supposed to chuck all that extra stuff in.
Started as a newbie with Flare 6.1, now using Flare 2018.
Report bugs at http://www.madcapsoftware.com/bugs/submit.aspx.
Request features at https://www.madcapsoftware.com/feedback ... quest.aspx
ChoccieMuffin
Propellus Maximus
 
Posts: 1935
Joined: Wed Apr 14, 2010 8:01 am

Re: inexplicable inline styles

Postby kirinawust on Wed Mar 13, 2019 1:34 am

The style is using autonumbering, but the inline coding is so much against the idea of using a css...
You are right, I will raise a bug, as I refuse to acknowledge this as "as designed" - and it wasn't the case in older Flare versions.

thx,
Irina
kirinawust
Propeller Head
 
Posts: 12
Joined: Tue Nov 05, 2013 5:08 am

Re: inexplicable inline styles

Postby ChoccieMuffin on Thu Mar 14, 2019 8:09 am

Let us know what they say. If they do add it as a genuine bug, I'll raise it as well.
Started as a newbie with Flare 6.1, now using Flare 2018.
Report bugs at http://www.madcapsoftware.com/bugs/submit.aspx.
Request features at https://www.madcapsoftware.com/feedback ... quest.aspx
ChoccieMuffin
Propellus Maximus
 
Posts: 1935
Joined: Wed Apr 14, 2010 8:01 am

Re: inexplicable inline styles

Postby kirinawust on Thu Mar 14, 2019 8:38 am

sure, will do

Best regards from Berlin, Germany
kirinawust
Propeller Head
 
Posts: 12
Joined: Tue Nov 05, 2013 5:08 am


Return to Styles, Stylesheets and XML

Who is online

Users browsing this forum: No registered users and 1 guest