EVERYTHING is italic? Sudden, weird font problems

This forum is for all Flare issues related to styles, stylesheets and XML.

EVERYTHING is italic? Sudden, weird font problems

Postby vaikanen on Thu Nov 15, 2018 9:11 am

I have no idea what is going on here. I can't think of anything I recently changed that would do this -- but when I opened my Flare project today EVERYTHING was italic. All headers, paragraphs, etc. It's Italic in the editor, italic in the output. All of it.

And I have no idea what could or would have caused this or how even a single "fat finger" change could cause all text in the Flare topic editor and the generated output files to show up as italic. It's bizarre. And severely annoying.

Anyone have any idea where to look or how to fix this? I'm still digging about in the project style sheet trying to track down the culprit...
vaikanen
Jr. Propeller Head
 
Posts: 7
Joined: Tue Sep 26, 2017 8:41 am

Re: EVERYTHING is italic? Sudden, weird font problems

Postby Dave Lee on Fri Nov 16, 2018 12:44 am

If you select Home > Formatting Window, the Formatting window shows the current style properties and where they came from.
Dave Lee
Master Propellus Maximus
 
Posts: 5821
Joined: Mon Mar 05, 2007 8:33 am
Location: UK

Re: EVERYTHING is italic? Sudden, weird font problems

Postby vaikanen on Wed Apr 10, 2019 1:18 pm

I solved this problem years ago, then ran into again today. Figured I'd post the fix this time.

Here's the cause: The Windows Font (Roboto in this case, which was being used as the Flare Font Family) was wonky/messed up/corrupted/whatever.

No idea how it happened or what caused it.

Fix:
I deleted the font from Windows/Fonts, re-downloaded and installed the font in Windows, and voila. Problem solved.
vaikanen
Jr. Propeller Head
 
Posts: 7
Joined: Tue Sep 26, 2017 8:41 am


Return to Styles, Stylesheets and XML

Who is online

Users browsing this forum: No registered users and 6 guests

cron