Defined styles not updated in Topic

This forum is for all Flare issues related to styles, stylesheets and XML.

Defined styles not updated in Topic

Postby davidgolden99 on Fri May 02, 2008 10:38 am

I have defined the h1 tag in a stylesheet, but it is not honored by the XML editor and doesn't appear in the Styles window. I checked the CSS link and my topic is definitely using the right stylesheet. When I select "Edit class" the stylesheet even displays the correct definitions. What's going on?
davidgolden99
Propeller Head
 
Posts: 29
Joined: Thu Apr 10, 2008 11:17 am

Re: Defined styles not updated in Topic

Postby LTinker68 on Fri May 02, 2008 11:15 am

Make sure you don't have the Stylesheet Editor set to the "print" medium when you make the changes (unless you're specifically setting the print version of the style). The Styles pane and drop-down menu probably show the styles in the "default" medium, but if you've specifically set something for print and not default, then it wouldn't show up.

Also, if you have a topic open in the XML Editor and you make modifications to the stylesheet, then you have to press F5 when the topic is active so that it refreshes (reloads) the stylesheet. (Changes made to the stylesheet aren't dynamically picked up by open topics.)
Image

Lisa
Eagles may soar, but weasels aren't sucked into jet engines.
Warning! Loose nut behind the keyboard.
LTinker68
Master Propellus Maximus
 
Posts: 7245
Joined: Thu Feb 16, 2006 9:38 pm

Re: Defined styles not updated in Topic

Postby KevinDAmery on Fri May 02, 2008 12:56 pm

Another potential gotcha is if there are two stylesheets with the same name but in different folders. Sometimes it isn't immediately obvious which one it's using. I've seen this happen if the project is imported from RH (the import won't automatically move the stylesheet to Flare's stylesheet folder).
Until next time....
Image
Kevin Amery
Certified MAD for Flare
KevinDAmery
Propellus Maximus
 
Posts: 1985
Joined: Tue Jan 23, 2007 8:18 am
Location: Darn, I knew I was around here somewhere...

Re: Defined styles not updated in Topic

Postby davidgolden99 on Fri May 02, 2008 1:07 pm

Selecting non-print fixed it. Thanks.
davidgolden99
Propeller Head
 
Posts: 29
Joined: Thu Apr 10, 2008 11:17 am


Return to Styles, Stylesheets and XML

Who is online

Users browsing this forum: No registered users and 7 guests