Style sheets assigned incorrectly?

This forum is for all Flare issues related to styles, stylesheets and XML.

Style sheets assigned incorrectly?

Postby hunsford on Fri May 30, 2008 1:44 pm

I think my style sheets are assigned incorrectly.

I have two style sheets in my project. The first one, Styles.css, is assigned by default to every topic. The second one, FirstTopic.css, is one that I want to use for some topics.

I have a topic to which I've assigned FirstTopic.css. When I edit the topic or open it in a browser window, it looks great; but when I preview it or generate WebHelp, the topic is continuing to reference Styles.css for most of its style information.

When I view the HTML code in Flare, the topic has a link to FirstTopic.css only. When I view the HTML from WebHelp, the topic has a link to three style sheets: FirstTopic.css, MadCap.css, and Styles.css.

Why is the generated Help referencing Styles.css? I went to Tools > Stylesheet Links, and FirstTopic.css is the only one listed as being assigned to the topic. There must be an easy setting to fix this that I simply don't know about -- I hope. :)

What setting do I change to fix this?
hunsford
Jr. Propeller Head
 
Posts: 3
Joined: Mon May 05, 2008 12:03 pm

Re: Style sheets assigned incorrectly?

Postby LTinker68 on Fri May 30, 2008 2:53 pm

hunsford wrote:Why is the generated Help referencing Styles.css? I went to Tools > Stylesheet Links, and FirstTopic.css is the only one listed as being assigned to the topic. There must be an easy setting to fix this that I simply don't know about -- I hope. :)

If you have a masterpage and it's linked to the Styles.css stylesheet, then it'll be included in every topic, but it won't be included until compile time, so it probably doesn't show up as being associated with the topic in the Tools > Stylesheet Links screen (I have a couple of masterpages but only one stylesheet so I don't have that problem).

The MadCap.css stylesheet is added automatically at build time and contains styles for the skin and other effects.
Image

Lisa
Eagles may soar, but weasels aren't sucked into jet engines.
Warning! Loose nut behind the keyboard.
LTinker68
Master Propellus Maximus
 
Posts: 7245
Joined: Thu Feb 16, 2006 9:38 pm

Re: Style sheets assigned incorrectly?

Postby hunsford on Fri May 30, 2008 3:41 pm

I had checked my master page, but I had expected the style sheet to be listed in the master page's Properties, as with regular topics.

Thanks for the advice. It worked to remove the style sheet from the master page -- so I was right, it was an easy setting to fix; I just didn't know where to look. :)
hunsford
Jr. Propeller Head
 
Posts: 3
Joined: Mon May 05, 2008 12:03 pm


Return to Styles, Stylesheets and XML

Who is online

Users browsing this forum: No registered users and 6 guests