MadCap Stylesheet Error

This forum is for all Flare issues related to styles, stylesheets and XML.

MadCap Stylesheet Error

Postby courtney on Tue Jun 03, 2008 9:19 am

I have been using Flare for some months now but have only just run into this problem. This problem occurs either when I close a Flare project and go back in or when I publish the final version. The problem is this:
I am using a previously defined stylesheet which contains the styles I need - perfect. Prior to closing or publishing the project, all is well and my topics reflect the styles in the stylesheet associated with them.
However, once I reopen the project or go back to the project once I have viewed the published output, every single topic is now associated with the MadCap stylesheet and the contents of each topic now have .MC styles instead of the previously defined styles from my stylesheet. Furthermore, everything on each page is right-justified (should be left-justified) and the header and footer banners that I have defined in the Master Page appear on each topic (so that if you publish the project as is, there is a duplication of headers and footers). Also, and most annoyingly, all my index entries disappear.
Even when I go into the Properties of each of the topics and reset the stylesheet to be the one I want, the topics remain as they are and I have to then amend them all.
My colleagues do not have this problem and we cannot see why this is happening to me.
I have looked on the Flare Help but cannot find anything about this problem.
Has anyone come across this problem and if so, do you have a solution ???
Grateful for any help!
courtney
Jr. Propeller Head
 
Posts: 3
Joined: Tue Jun 03, 2008 1:59 am

Re: MadCap Stylesheet Error

Postby LTinker68 on Tue Jun 03, 2008 9:30 am

By any chance, do you have your project set up to build your output back into your content folder?
Image

Lisa
Eagles may soar, but weasels aren't sucked into jet engines.
Warning! Loose nut behind the keyboard.
LTinker68
Master Propellus Maximus
 
Posts: 7245
Joined: Thu Feb 16, 2006 9:38 pm

Re: MadCap Stylesheet Error

Postby courtney on Wed Jun 04, 2008 5:34 am

Thank you for that Lisa.
I have noticed that when I publish a project, sometimes it is published to Output/lcc/MyWebHelp - which is what I would expect, however sometimes a Content folder appears under the Output folder. I don't know if this has any bearing on it?
courtney
Jr. Propeller Head
 
Posts: 3
Joined: Tue Jun 03, 2008 1:59 am

Re: MadCap Stylesheet Error

Postby Dave Lee on Wed Jun 04, 2008 7:48 am

It does sound like you've either got the target output folder or publish destination folder set to your working project folder. If you have done this then you've overwritten your working topic files with the output files (and I hope you've got a backup from before it happened, otherwise you're pretty stuck).

What you need to check:
- Open your target, and on the Basic tab check the Output Folder isn't your working project folder. Just set it to (default) unless you have a reason to keep the output elsewhere.
- Check that your publish destination isn't the same as your working project folder.
Dave Lee
Master Propellus Maximus
 
Posts: 5822
Joined: Mon Mar 05, 2007 8:33 am
Location: UK

Re: MadCap Stylesheet Error

Postby courtney on Wed Jun 04, 2008 9:05 am

Thanks very much guys - that was definitely the problem and all is now resolved!
Unfortunately, I do have to go back into some of the topics that were overwritten and amend them but at least I know what the problem is.
Thank you again for your advice.
courtney
Jr. Propeller Head
 
Posts: 3
Joined: Tue Jun 03, 2008 1:59 am


Return to Styles, Stylesheets and XML

Who is online

Users browsing this forum: No registered users and 5 guests