Error with Visual Source Safe

This forum is for all Flare issues related to using Source Control.

Error with Visual Source Safe

Postby dapayne on Thu Apr 26, 2012 8:18 am

I'm not real sure where my issue is here. I was previously working on a server and would have flare connect to another server where my repository was. I did not have issues with this.

Now I am moving my work to a new server and connecting to the same repository on another server. The project appears to be bound correctly.

However, when I go to check out a file, it proceeds as if with no error, but does not remove the "locked" symbol from the file. Similarly, if I go to save the file, it fails to save because it seems to think the file is locked and it does not think it is checked out. When I compare my repository, I can see the file is in fact checked out.

I figured this was an issue with flare writing to the directory, so I tried working with an unbound project and it worked fine. So this issue only manifests itself when I am trying to make changes to an existing file in source control.

Differences between the two work servers - the old one is Win 2003 Server, VSS 2005, the new one is Win 2008 Server R2 and VSS 2008. Both use Flare 7
Jr. Propeller Head
Posts: 1
Joined: Thu Apr 26, 2012 7:59 am

Re: Error with Visual Source Safe

Postby JohnB on Thu Apr 26, 2012 10:50 am

This sounds the same as the issue I encounter. Here's how I work around it, in more or less a single step, maybe it will work for you:

1. In the Content Explorer pod, right-click the file you want to change, and select Properties.
2. Clear the Read Only option, and click OK. The Check Out dialog appears.
3. Click Check Out.

Now there must be an option somewhere to set 'always check out as writeable', but I haven't found it, or at least it didn't work for me with Flare.

- John
Propeller Head
Posts: 50
Joined: Mon Nov 09, 2009 12:17 pm

Return to Source Control

Who is online

Users browsing this forum: No registered users and 1 guest