Page 1 of 1

SVN broken in Flare 12?

PostPosted: Tue Apr 05, 2016 2:07 pm
by doc_guy
I had a project in Flare 11 that worked great with SVN integration with Cloudforge (an online source control repository). However, when I (and my client) upgraded to Flare 12, the source control system stopped working completely. No error messages, just when you try to do something it just doesn't DO anything.

I'm wondering if SVN is broken in general in Flare 12 (I don't have another SVN repository to compare it to), or if it is just Flare 12 and Cloudforge. I'm not the only one with issues with SVN, but we all seem to be using Cloudforge.

Re: SVN broken in Flare 12?

PostPosted: Thu Apr 07, 2016 9:15 pm
by doc_guy
Seems to be only an issue with Cloudforge, for some unknown reason. When I use a different SVN cloud provider (like Assembla) SVN works fine in Flare 12.

Re: SVN broken in Flare 12?

PostPosted: Wed Apr 13, 2016 5:54 pm
by surfWriter
I'm a bit new to Flare (one year) and spent many hours pulling my hair out trying to merge conflicts the past couple days after upgrading from Flare 11 to 12 a week ago. We use SVN 1.8.10 and Tortoise 1.8, but use Flare's built-in source control interface to SVN for all things Flare.

If there were any conflicts at all, both Update and Add/Commit attempts would cause Flare to crash. Upon restart, EVERY file would be temporarily marked as new (plus sign). Flare wouldn't let me add/commit brand new files or get another writers newly added files without first resolving all conflicts. I had made some wholesale changes to style classes and settings for various targets that I could easily reproduce, so thought that rolling back my changes and then redoing them would work, but alas the Undo My Changes option wouldn't work. I made a backup of the SVN repository and tried the option to discard external changes, but that didn't work, either.

In the end, after dozens of crashes and numerous messages that folders/files were locked (even though the Unlock icon was disabled and no locks were shown through Tortoise or SVN, either), I had to go through the manual conflict resolution for every conflict in every file in order, one at a time. Is that normal? It was excruciating. I'm sure either I or the other (brand spanking new) writer did something wrong, but can't for the life of me figure out what.

For the time being, I'm wondering if it's safest to just commit and update files constantly in extremely small batches. Our project has 5K topics and 100 targets and I'm doing a lot of rebranding and restyling, as well as technical updates.

Re: SVN broken in Flare 12?

PostPosted: Mon Apr 18, 2016 1:46 pm
by doc_guy
Hey surfwriter,

Welcome to the forums.

First, I'd raise the issue with MadCap Support. You are not the only person suffering through changes in Flare 12 that have broken SVN for some users.

Curiously, it is not a universal problem. I only have the problem when I work with specific source control providers (CloudForge) where I don't have the problem if I work with other source control providers (Assembla). Clearly something in Flare 12 has broken SVN for many of us. Hopefully MadCap will get enough information from those who are affected that they are able to identify and squash this bug.

Re: SVN broken in Flare 12?

PostPosted: Mon Apr 18, 2016 3:08 pm
by surfWriter
Thanks, Paul, I posted a bug report about conflict resolution. Hope my report helps instead of just further confounding the issue, because I honestly can't recall the exact details of when the various crashes and errors arose :oops: And since my fellow writer is gone for 6 weeks, I can't work with her to replicate it....and I'm buried.

Re: SVN broken in Flare 12?

PostPosted: Fri Apr 22, 2016 11:08 am
by dcisneros
I'm not using SVN, but the same exact thing happened to me with the Git integration. Things were working fine in Flare 11, but when I upgraded to 12, none of my changes were getting pushed to the repository. No error message, but absolutely nothing happens.

I brought it up to support at MadWorld and took my laptop so they could see what was happening, and while they weren't able to resolve it then, they did say they'd continue look into it and open a bug on it.

Re: SVN broken in Flare 12?

PostPosted: Tue Aug 16, 2016 7:16 am
by dpoole
I'm using Flare 12 and Windows 7 with Subversion as source control. My issue is that Flare "disconnects" from source control and the Reconnect button on the Source Control tab won't work... well won't work consistently! It's so frustrating. I've logged a ticket and even had a Flare rep look at my system, and of course, when he was looking everything connected perfectly. Today when I depress the button, Flare thinks and thinks and then does nothing. Previously, as a workaround, I could open my project with Flare 11 and have the connection to Subversion. But today, when I open in Flare 11, the project is not connected to source control and in 11, there is not a manual way to "reconnect" of which I'm aware. ugh.

The project properties in both Flare 11 and Flare 12 show that the project is bound to Subversion. From what I've read, this disconnect/reconnect feature in Flare 12 lets users disconnect and reconnect for working offline. But for me, Flare seems to be making the decisions instead of letting me have control.

I work from home over VPN some days and I'm wondering if VPN could be part of the issue. I never had these issues with Flare 11.

Has anybody else seen this? Does anyone have any ideas?

Re: SVN broken in Flare 12?

PostPosted: Tue Aug 14, 2018 4:14 pm
by Bambina_Mena
Add me to the list (who from Madcap will help?).
I use Flare v12 with Tortoise SVN. The same problem is happening for me. I've existing projects that are bound to SVN. One day everything is fine re: I can check out current and check in updates. A day or two later, I open the same project and it is not bound to source control. However, Project Properties shows it as bound to SVN. Can anyone help? This only began happening with a v12 upgrade. We still have Platinum support and I'm going to contact MadCap directly.
8/15 UPDATE:
I phoned MadCap Support this morning. For now, now good. The rep said, "Although I have seen this issue, I am not sure what may be causing the binding to fail frequently. I will have to do further research on this matter. I will update you with my findings."
I am going to revert to my previous Flare version.

Today I found a workaround that I will use until MadCap figures this one out. BTW, my source control is Tortoise Subversion.

From Flare, right-click the target.
Select Source Control.
Select Reconnect.
After I've reconnected, I am able to commit any updates not in SVN.