Disappearing .eps images with TFS and Flare 13

This forum is for all Flare issues related to using Source Control.

Disappearing .eps images with TFS and Flare 13

Postby dtmenges on Tue Mar 14, 2017 7:10 am

I am using Flare 2017 (Ver 13 64-bit) and TFS. I've have managed to get Flare confused about an .eps image. I have checked out the .eps, edited with Illustrator and checked in but somewhere along the line Flare has gone absolutely stupid with a cache of this file. I had this happen once before and had to checkout the file, close Flare, rename the file and then go back into Flare and reinsert the file. I'm running out of creative ways to name this illustration.

In the XML everything looks okay. I can even open the file in Illustrator from Flare and see the image but double-clicking the .eps in Flare to see a preview doesn't work. The same for building a preview in the topic or building a target. Flare leaves space for the .eps but doesn't insert anything.

So my question is, how do you edit an .eps for Flare 2017 and not have these issues? Close Flare entirely? That didn't need to happen when using VSS and Flare 11.

I do have a bug report in to Madcap on a related issue about Flare not checking in a changed .eps. That seems to be pretty consistent, this disappearing image, not so much. If I have to sacrifice a chicken under a full moon I'll do that but I need to be producing content not debuging Flare and TFS,
dtmenges
Propeller Head
 
Posts: 95
Joined: Tue Oct 28, 2008 6:38 am
Location: Goshen, IN

Re: Disappearing .eps images with TFS and Flare 13

Postby dtmenges on Thu Mar 16, 2017 8:35 am

On a related anomaly, I have .eps previews that don't updated.
Closed all topics
Checked out an .eps.
Made and saved changes with Illustrator.
Checked the file in and the preview doesn't update.

All check ins and checkouts were done with Flare 13.
dtmenges
Propeller Head
 
Posts: 95
Joined: Tue Oct 28, 2008 6:38 am
Location: Goshen, IN

Re: Disappearing .eps images with TFS and Flare 13

Postby dtmenges on Mon Mar 27, 2017 6:54 am

I also had .eps files that didn't update and that got cured with a related issue that MadCap support helped me with last week. I wanted to be sure I was happy before I posted.

My other issue was checking out an .eps file, editing in Illustrator, and then I couldn't check the file in with Flare. This was in several projects that originally were bound to Visual Source Safe but coincidentally with updating to Flare 13, I had move to TFS.

After several email exchanges, Support did a remote. The solution is:

1. Make sure everything is on the TFS server.
2. Unbind the project in Flare.
3. Close the project.
4. Use Visual Studio to unmap the project from the local project. You may need your TFS admin to help with this.
5. Rename your local project folder.
6. Go back to Flare and import from the TFS server. (File>New Project>Import Project). This now becomes your local copy.

That has worked for me for three projects and I have had no issues with checking in and out or preview problems. By renaming your original local folder, all of your original work stays on your computer just in case.

Support didn't really say what the problem is but I believe the problem is that some database info may have been left behind in the Analyzer folder. That is just my SWAG based on how some of our software works.

Hope this helps.
dtmenges
Propeller Head
 
Posts: 95
Joined: Tue Oct 28, 2008 6:38 am
Location: Goshen, IN


Return to Source Control

Who is online

Users browsing this forum: No registered users and 2 guests