Flare/Git Integration Overwriting New Content with Old

This forum is for all Flare issues related to using Source Control.

Flare/Git Integration Overwriting New Content with Old

Postby jane-tron on Fri Aug 03, 2018 12:29 pm

My team is having some major problems with our Git/Flare integration. It is blocking our ability to work. We are not sure if it’s a problem with Flare or Git, or if it’s a user error. We need to track down the problem and find a solution.

On multiple different occasions, Flare has included topics in a user’s commit/sync that the user did not change. These older versions of the topics overwrote newer versions that had previous been pushed by other users. Our Flare/Git integration has worked without any major problems up until a week ago.

Has anyone had a problem with Git replacing new content with old? Checking in files that the user had not touched?

Jr. Propeller Head
Posts: 6
Joined: Tue Dec 23, 2014 3:49 pm

Re: Flare/Git Integration Overwriting New Content with Old

Postby Nita Beck on Sat Aug 04, 2018 6:03 am

What I’m about to describe might not be relevant to your situation, but I’ll describe it nonetheless in case it sheds any light...

My habit at the end of each work session (day) is to make sure that I’ve got all my changes committed and pushed. I’m sure that is your and your colleagues habit as well.

One time, when I next opened a project and updated all from the repo, I was perplexed to see that there was a bunch of files seemingly in a checked-out state, files that I had not been working on. (And, perplexingly, Flare did not prompt me to commit before getting the latest updates, which it would have done if files truly were in a checked-out state.) Hmmmm.... So I immediately attempted to commit them. Hmmmm.... Nothing to commit. Hmmmm.... So next I did a revert all. Bad move. My production assistant (who’s in a different time zone) contacted me a couple of hours later to report that all of his changes from the previous afternoon had been lost. He asked why I had reverted them. Hmmmm.... So I never did that again.

I continue to see these false checked-out files on occasion when I first open a project that I *know* has no checked-out files. I’ve tried to refresh individual files. No dice. I’ve tried to refresh all. No dice. But what has worked in this: I right-click on one of the files and select Source Control, which opens the list of source control commands. Interestingly, the Commit command is not available, so I close the menu. At that point, Flare seems finally to “catch up” and the little red checkmark next to the file is now gone. They’re gone from all the other files, too. And now I can start my work...

In summary, I think there is a bug in Flare by which Flare is confused about the source control status of files when a project is first opened. In my experience, this is not new to Flare 2018. I’ve seen this behavior in Flare 2017 r3 as well.


P.S. I know that you’ve posted your question in the MadCap Flare User Groups community on Slack. I’ll copy my reply to that thread for benefit of that community, too.
Content Strategist / Information Architect / Flare Consultant: http://beck-communications.com
Manager, Rochester Flare User Group: http://www.facebook.com/RochesterFlareUserGroup
Nita Beck
Senior Propellus Maximus
Posts: 3402
Joined: Thu Feb 02, 2006 9:57 am
Location: Pittsford, NY

Return to Source Control

Who is online

Users browsing this forum: No registered users and 1 guest