Page 1 of 1

Flare - Gerrit - Git Problems

PostPosted: Tue Oct 09, 2018 6:36 am
by joshua_cline
Has anyone successfully integrated Flare and Git when the company uses Gerrit Code Review as the UI for Git?

We are new to Flare and want to use Git for our source control. Our company uses Gerrit Code Review as the UI for Git, and they have it set up so that developers cannot check in code without a work item number (from version 1) and approvals from other developers for code reviews before the code can be pushed into the remote repository--and probably a lot of other things.

When the docs team binds Flare projects to Git (with push on bind selected), the process appears to be working, but then we get all sorts of errors. One says the "Specified remote repository is already bound to, select a newly created repository or import from this one." But when we look in the remote repository, it is empty. We spoke to Madcap Support and one change was to go into Option and set Flare to automatically check for GIT bindings on opening the project, so we closed and reopened the project and all seems well.

Commits worked fine, but since a commit is no different than a save, we felt it should. Pushes on the other hand gave errors: "Push failed due to :'prohibited by Gerrit; ref update access denied", and no email from Git.

Madcap Support has spent hours with us regarding this problem, but we haven't made any progress. Our Release Engineering team tried changing permissions and we got a little further: we got an email but the repository remains empty.

After permissions were changed we got an error from Git about not having a topic, which in our Git/Gerrit land is the work item number from Version1. There’s no place in Flare to enter a work item number.

Has anyone else had similar issues, or worked with Gerrit/Git and Flare? Any suggestions?

Re: Flare - Gerrit - Git Problems

PostPosted: Tue Oct 09, 2018 6:51 am
by joshua_cline
Also, when you make a change in a topic (Project) and commit, then the objects and index update in the .git folder, but when you make a change to a topic and then ctrl-z (e.g., delete a period and add it back in), and try to commit, Flare does not recognize that change. And, therefore no commit. Anyone else see this? Is this normal?