Page 1 of 1

Flare crashes when connecting to GIT

PostPosted: Thu May 02, 2019 2:05 am
by Jana Ostyn
I'm have a series of Flare projects binded to GIT repositories. The whole setup has been working fine for several years, but recently Flare started crashing whenever it connects to GIT. Flare just shuts down, without any message. This happens when:

- I try to import the most recent files on opening a project
- I try to push and pull files

The problems occurs with Flare2018r2 and Flare2019. I tried reinstalling Flare, but nothing seems to work. Anybody has any ideas?

Re: Flare crashes when connecting to GIT

PostPosted: Thu May 02, 2019 5:11 am
by Nita Beck
Welcome to the forums! :)

Does this happen with all of your Git-bound projects or with only one?

If only one, I suggest that you import a fresh copy of the project from the remote repo. So use File > New Project > Import Project (...from source control; I might have the command name wrong; I'm not looking at Flare at the moment). You'd then have to recreate any changes you made in the old project in the new project. When done, abandon the old project.


Re: Flare crashes when connecting to GIT

PostPosted: Thu May 02, 2019 6:08 am
by Jana Ostyn
It happens with all my projects. I tried importing fresh copies for some projects, but the import causes Flare to crash as well (when cloning the GIT repository).

Re: Flare crashes when connecting to GIT

PostPosted: Thu May 02, 2019 8:36 am
by Nita Beck
I think this merits contacting MadCap tech support, then.

Re: Flare crashes when connecting to GIT

PostPosted: Thu Jul 04, 2019 7:40 pm
by nat
Hi Jana, have you had any luck with this?

My installation of Flare has started doing this too. I can connect to BitBucket (my source control repository) using GitKraken, but Flare is timing out every time I try to connect. Yesterday it was also crashing.

I tried clearing out my folder and doing a fresh import (git clone). Flare can't/won't connect, but GitKraken can. This tells me it's a problem with Flare - not a problem with my repository, or with the git installation on my laptop, or my proxy settings etc.

I just now submitted a support request.

Cheers, Nat

Re: Flare crashes when connecting to GIT

PostPosted: Tue Jul 30, 2019 3:34 am
by Techno
Are any of you getting the following error coming up?

Pulling local changes from remote...
Error occurred in LibGit2Sharp : failed to start SSH session: socket disconnect

I'm told by Flare support that this is caused by issues with the Windows 10 Version 1903 update.

While I accept I can fight my way through a gitbash session, it is nevertheless a pain.

Does anyone have any insider knowledge of when we might see a fix?

Re: Flare crashes when connecting to GIT

PostPosted: Thu Aug 22, 2019 4:38 pm
by sarahb
I'd love the fix for this too. I just had one team member get a new laptop (Windows 10 OS) and is going through the process of importing our team Flare project on his new laptop. Flare 2017R3 just crashes during the import project phase, before he even gets to select his SSH keys. I had him try installing the newest Flare trial version, and while it still fails at the same point, he at least gets to see an error message this time: "Failed to start SSH session".
I have 18 other people, including myself, who have been using this project for years without any issues.

Oh, I also had him try importing the project via a Git Bash clone operation. This does actually import the project (at least it gets him further than trying to import the project through Flare), but when he opens the project, and browses to the location of his SSH key when prompted, it then throws the same "Failed to start SSH session" error.

If anyone managed to solve this issue, please let me know!

Re: Flare crashes when connecting to GIT

PostPosted: Fri Aug 23, 2019 1:16 am
by Techno
I'm not sure where Madcap policy stands here, so may be out of line with my response. However, I suggest you telephone Flare's support and ask about a fix which is in the works for this problem.

This week I was asked to check out a new version to ensure it resolved things, and so far, I do not appear to have hit any snags on my desktop system which is running the very latest Windows 10 Version 1903 on a DELL OptiPlex 7060.

I fairness to Madcap, they are not alone with what appears to be a security tightening by Microsoft. It scares the heck out of me since over the summer vacation, many educational establishments here in the UK will have had their systems upgraded, affecting at least one product we supply to them.

If you hit a brick wall with Flare, come back to me and I will name two people who are aware of the progress of this fix.

Re: Flare crashes when connecting to GIT

PostPosted: Fri Sep 20, 2019 12:41 pm
by RandyMan
I ran into this problem Wednesday. Thanks to this forum, a work-around solution was achieved today ... after 48 hours of Madcap lockout (zero productivity). Now, I admit I am a bit cranky after two days of twiddling my thumbs, but this is a Madcap-sponsored (and moderated...I hope) forum. As such, it would have been nice to learn about this problem from an official Madcap source when it was first discovered (months ago based on the postings in this discussion).

Many here are probably very fluent in Git and have considerable knowledge of Windows. However, I suspect there are many here who focus on the communications part of the job more than the underlying technologies that enable the delivery of those communications. For all of those people, my message to Madcap is simple: Please help us. When you learn of a bug, consider sending out a proactive message/email to all users. It doesn't have to be lengthy or complicated...maybe the following for example,
"We've learned about an issue associated with the 1903 update for Windows 10. This issue is XYZ... We are working on a patch to address this issue and will let you know when it is ready. Until then, you can work around this issue by doing ABC."

Communication is key. We get there are software bugs. Please help us be productive when you're aware of them. Thank you for listening if you are.

In the meantime, thank you very much to the contributors in this forum who posted the workaround. Personally, I'm using GitBash >> git status >> git pull >> git push to get the files to/from the repo. We have a small team, so this works well. Many of them haven't had the 1903 update pushed to them yet, so we're a mixed bag. At least we have an answer/solution now....thanks to you all!

Re: Flare crashes when connecting to GIT

PostPosted: Fri Sep 20, 2019 3:41 pm
by Techno
I quite agree with you, but being in contact with clients as much as I am there are two side to this issue.

1) Madcap's system appears to be based on the number of reports before they take serious action. Yet one Source Control issue often affects man users!!

2) Few administrators upgrade systems for some time after a release. This is particularly prevalent in our UK education system (and I guess elsewhere too) when admins will use the summer vacation period to upgrade dozens, or even hundreds of PCs in schools.

In our case, the one reason I keep our systems as fully up to date as possible, is simply to be as aware as possible of any problems which arise with the products we both sell and support.

Having said that, it is clear that as Madcap could not replicate the problem, they clearly do not have a similar policy - more's the pity!

And even more annoying is that having sent me a beta to test some time go, it has not yet been released to users.

- George

Re: Flare crashes when connecting to GIT

PostPosted: Mon Oct 14, 2019 5:33 am
by sunil_panchal
I've run into the problem too. I'm running Windows 10 Pro build 1903 and Flare 2019 r2. I've submitted a support case to Madcap.

Re: Flare crashes when connecting to GIT

PostPosted: Mon Oct 14, 2019 7:03 am
by Techno
Having been using a beta test to overcome the problem, I have now applied the latest 2019 r2 version of Flare just released, and the problem has certainly been resolved here.

I did also ask MadCap who confirmed that it had been addressed, although at the time was not documented as such.

Although you may be on the Windows 10 version 1903, have you applied all updates to Windows? Since I believe Microsoft now own GIT, I guess it's possible that a fix was required on their end as well. FYI the OS Build I have here is 18362.418.