Dot Net Viewer installer doesn't write its registry keys

This forum is for all Flare issues related to the DotNet Help target, and the Dot Net Viewer

Dot Net Viewer installer doesn't write its registry keys

Postby Cheetah on Fri Feb 03, 2012 1:52 pm

I've found that the "SetupMadCapHelpViewer0610.msi" does not appear to write registry keys that the Madcap.HelpViewer(Embedded)Client DLLs are expecting to find.

The client DLLs for v6.1 are hard coded to look for a file path for v6.0, or to look for the install path in a registry key. But the installer isn't writing that registry key on any system I've tried (Win7 x86 and x64).

I finally tried just running the stand alone help viewer once, and that wrote the registry keys.

Those keys should REALLY be written by the installer, and the client DLLs should be updated with the correct path.

It's very confusing and a bad experience to require the end user to run what seems to them like a random app that shows them nothing, asks them irrelevant questions, and wants them to install yet more seemingly unrelated software in order to be able to view the help in our app.
Cheetah
Jr. Propeller Head
 
Posts: 1
Joined: Fri Feb 03, 2012 1:37 pm

Re: Dot Net Viewer installer doesn't write its registry keys

Postby RamonS on Fri Feb 03, 2012 3:11 pm

Did you make sure that this isn't a permissions issue? Not saying it is, but a lot falls apart when it comes to writing to the registry without proper rights.
RamonS
Senior Propellus Maximus
 
Posts: 4291
Joined: Thu Feb 02, 2006 9:29 am
Location: The Electric City


Return to DotNet Help and the Dot Net Viewer

Who is online

Users browsing this forum: No registered users and 1 guest