Problems after updating MadCap Help Viewer

This forum is for all Flare issues related to the DotNet Help target, and the Dot Net Viewer

Problems after updating MadCap Help Viewer

Postby EmJay on Mon Sep 07, 2009 7:21 am

Hello everybody,

I developed a software with Visual Studio .NET 2008 (C#) and added the MadCap.HelpViewerEmbeddedClient.dll version 4.0.16.29615
as link in the project. When the user installs the MadCap Help View version 4.0 on his PC it is possible to use the embedded client
of my software but after updating the MadCap Help View version 4.0 to any other version (e.g. 4.2) it doensnt' work anymore.

What did I do wrong?

Thanks for your help.

EmJay
EmJay
Jr. Propeller Head
 
Posts: 8
Joined: Mon Aug 18, 2008 6:00 am

Re: Problems after updating MadCap Help Viewer

Postby RamonS on Mon Sep 07, 2009 8:07 am

Did you recompile the DotNetHelp using the matching Flare version? If not, then this could be the problem. So if you use the 4.2 viewer you'd need to recompile the DotNetHelp using Flare 4.2. Upgrading of the DotNetHelp components seems to be only advised if you gain something from the new version, otherwise it seems to be too much work for what its worth. So, one option would go back to the version that did work out for you before.
RamonS
Senior Propellus Maximus
 
Posts: 4286
Joined: Thu Feb 02, 2006 9:29 am
Location: The Electric City

Re: Problems after updating MadCap Help Viewer

Postby EmJay on Mon Sep 07, 2009 10:51 pm

Hello RamonS,

I try to explain it again.

I developed a software which uses the MadCap.HelpViewerEmbeddedClient.dll version 4.0.16.29615.
When a customer installs my application on his PC the MadCap Help Viewer version 4.0 will be installed automatically, so
that the customer can use the dynamic help of my application without any problems. OK!

In case the customer updates the MadCap Help Viewer version 4.0 on HIS computer to any other version (e.g. 4.2)
it is not possible to use the dynamic help of my application. And here is my problem. MadCap Help Viewer 4.0 informs the
user that a new version is available and in case he updates it, all applications which uses the old dlls
(e.g. MadCap.HelpViewerEmbeddedClient.dll version 4.0.16.29615) doesn't work anymore correctly.

You can open the help files with the MadCap Help Viewer directly but not dynamically from the application. :-(

I would be great if you can help me.

Best regards,

EmJay
EmJay
Jr. Propeller Head
 
Posts: 8
Joined: Mon Aug 18, 2008 6:00 am

Re: Problems after updating MadCap Help Viewer

Postby RamonS on Tue Sep 08, 2009 4:12 am

Ah, now even I get it. I admit that I rarely get in touch with DotNetHelp, typically the Flare help. My recommendation is to contact MadCap support for immediate assistance and file the behaviour as a bug here: https://www.madcapsoftware.com/bugs/submit.aspx
The viewer shouldn't propose an update or at least it should be possible to configure the viewer not to do so.
RamonS
Senior Propellus Maximus
 
Posts: 4286
Joined: Thu Feb 02, 2006 9:29 am
Location: The Electric City

Re: Problems after updating MadCap Help Viewer

Postby EmJay on Tue Sep 08, 2009 4:29 am

Hello RamonS,

thanks for your quick response. I send the bug already to MadCap support.

Best regards,

EmJay
EmJay
Jr. Propeller Head
 
Posts: 8
Joined: Mon Aug 18, 2008 6:00 am

Re: Problems after updating MadCap Help Viewer

Postby alex on Wed Mar 03, 2010 10:03 am

Does anyone know whether this issue has been fixed in V6? We would not want the user to be prompted to update the help viewer, either.

Thanks,
alex
alex
Propeller Head
 
Posts: 95
Joined: Fri Aug 25, 2006 11:22 am


Return to DotNet Help and the Dot Net Viewer

Who is online

Users browsing this forum: No registered users and 2 guests