Page 1 of 1

Page numbers appearing in online Xrefs

PostPosted: Mon Oct 24, 2016 6:17 am
by Finner
I have set up my project to print as a PDF and to produce HTML5 output. Most of my links are cross-references, using Madcap:xref. In the PDF output the link appears with a page number, as it should. Unfortunately, in the online output the link appears with a page number as well (always "1"). This happens regardless of which medium I choose as Primary. I also tried using "Tools-Update Cross-References" but this doesn't solve the problem either. Any ideas what would cause this?

Re: Page numbers appearing in online Xrefs

PostPosted: Mon Oct 24, 2016 6:41 am
by Finner
I just answered my own question by following the instructions under http://www.flareforhelp.com/page/55/ .
For my HTML5 target, I went to the "Advanced" tab and found that "Stylesheet medium" was set to "print." After I changed that to "non-print" and rebuilt the HTML5, the page numbers no longer appeared in online output.

Re: Page numbers appearing in online Xrefs

PostPosted: Wed Mar 29, 2017 1:22 am
by machivv
Does that mean you need a different stylesheet for a pdf output and for a web output?

Re: Page numbers appearing in online Xrefs

PostPosted: Wed Mar 29, 2017 1:50 pm
by paintedturtle
machivv wrote:Does that mean you need a different stylesheet for a pdf output and for a web output?


Yes! Definitely.

Re: Page numbers appearing in online Xrefs

PostPosted: Thu Mar 30, 2017 12:00 am
by Matze
I suppose not. You can use one style sheet for all stuff. Switch the medium in the stylesheet editor from default to print or non-print as required.