Variables not resolving correctly in CHM built via batch

This forum is for all Flare issues related to the Microsoft HTML Help target.
This target produces "CHM" files in the output.

Variables not resolving correctly in CHM built via batch

Postby Nita Beck on Wed Jan 09, 2019 7:53 am

Has anyone had issues with Flare 2018 r2 not processing variables correctly for CHM targets that share a skin and specifically when built via a batch target triggered by Windows Task Scheduler? This behavior can be reproduced in new projects; it did not occur prior to 2018 r2. It applies only to CHM targets, not HTML5 or print.

My client describes the behavior this way: "...when the batch target is run via Scheduled Tasks, it resolves the variable in the skin (for chm), but the next target that uses that same skin will use the resolved variable of the previous target. And this goes for the targets that come next in line and use that same skin. When you omit the first target (from the batch), then the variable in the skin is resolved in the second target. This resolved variable will be used in the targets that come next in line and that use that same skin."

MadCap tech support has not yet offered a solution. Anyone else seeing this behavior?

(Cross-posted in the Flare Slack community)
Nita
Image
Content Strategist / Information Architect / Flare Consultant: http://beck-communications.com
Manager, Rochester Flare User Group: http://www.facebook.com/RochesterFlareUserGroup
Nita Beck
Senior Propellus Maximus
 
Posts: 3269
Joined: Thu Feb 02, 2006 9:57 am
Location: Pittsford, NY

Re: Variables not resolving correctly in CHM built via batch

Postby Nita Beck on Thu Jan 10, 2019 5:37 am

MadCap can reproduce the issue and has confirmed it as a bug...
Nita
Image
Content Strategist / Information Architect / Flare Consultant: http://beck-communications.com
Manager, Rochester Flare User Group: http://www.facebook.com/RochesterFlareUserGroup
Nita Beck
Senior Propellus Maximus
 
Posts: 3269
Joined: Thu Feb 02, 2006 9:57 am
Location: Pittsford, NY


Return to Microsoft CHM Help

Who is online

Users browsing this forum: No registered users and 2 guests