CHM Builds but Won't Run/Open

This forum is for all Flare issues related to the Microsoft HTML Help target.
This target produces "CHM" files in the output.

CHM Builds but Won't Run/Open

Postby MkMr on Mon Aug 17, 2009 2:58 pm

Uh oh.. not sure what changed or went wrong. But now when I generate my help file it is twice the size as it was previously (was 28mb and is now 56mb) and when I double-click it to run I get the message:
Cannot open the file "mk:@MSITStore:C:\path\blah\blah\blah.chm.


I'm using Flare V5. There are no errrors when I generate the help. I don't see anything strange in the log.

Anybody ever seen anything like this? Any help appreciated.

Propeller Head
Posts: 17
Joined: Tue Sep 25, 2007 7:29 am

Re: CHM Builds but Won't Run/Open

Postby KevinDAmery on Tue Aug 18, 2009 5:24 am

I may be imagining things, but I seem to recall a thread here where someone said they were able to solve a similar issue by re-registering the itcc.dll.
Until next time....
Kevin Amery
Certified MAD for Flare
Propellus Maximus
Posts: 1985
Joined: Tue Jan 23, 2007 8:18 am
Location: Darn, I knew I was around here somewhere...

Re: CHM Builds but Won't Run/Open

Postby MkMr on Tue Aug 18, 2009 12:25 pm

Hi Kevin,

I gave itcc.dll a try but it didn't make a difference. Next I tried using Flare v4.2 instead of 5.0.


That worked. Help file runs no problem. Whew!

Not sure what's up with 5.0 but I can't use it.

Propeller Head
Posts: 17
Joined: Tue Sep 25, 2007 7:29 am

Re: CHM Builds but Won't Run/Open

Postby MkMr on Tue Sep 29, 2009 3:16 pm

The solution to this issue as to copy the .flprj file, as well as the Contents and Project folders to a fresh directory. When built from this new location the CHM is normal size and runs no problem.

Propeller Head
Posts: 17
Joined: Tue Sep 25, 2007 7:29 am

Re: CHM Builds but Won't Run/Open

Postby Madcap Guru on Thu Oct 01, 2009 10:55 am

if you open a different or sample project and build it does it work?
Rick Ferrell

Former Flare and Robohelp Support
Madcap Guru
Sr. Propeller Head
Posts: 234
Joined: Tue Mar 17, 2009 10:41 pm

Re: CHM Builds but Won't Run/Open

Postby MkMr on Thu Oct 01, 2009 12:41 pm

Yes other projects build fine. It was, oddly, just this one project in this particular location. Strange - but the workaround is painless so I'm back to using Flare 5.

Propeller Head
Posts: 17
Joined: Tue Sep 25, 2007 7:29 am

CHM build is double its previous size and won't open

Postby paulblusas on Thu Jul 01, 2010 4:12 am

I'm using Flare 4.1 (for softwrae project reasons) and have just met this problem for the first time on my main Flare project. Previous builds for this Flare project have been fine. Current builds of other Flare projects that are linked into the main Flare project still work fine.

I have tried both moving the main Flare .prj file and all relevant folders for this project to a new directory location as suggested in one reply in this topic and also re-registering the .itcc.dll as suggested in another - but to no avail.

It's looking like a Flare Support ticket unless anyone else has met the problem and found a different solution / workaround.

Paul B
Propeller Head
Posts: 18
Joined: Tue May 01, 2007 7:07 am
Location: Kingston upon Thames, UK

Re: CHM Builds but Won't Run/Open

Postby Robotman on Wed Nov 17, 2010 9:45 pm

I solved this one by opening the CHM target, and in the General pane ensure that the STARTUP TOPIC is NOT set to (default).

So, if you set Startup Topic to a particular topic then you won't get that error when opening the CHM file.
\m/ Gary \m/
Flare 2017 r2 / Windows 10 64-Bit
Screaming Symphony
Sr. Propeller Head
Posts: 183
Joined: Sat Mar 04, 2006 3:05 am
Location: Melbourne, Australia

Re: CHM Builds but Won't Run/Open

Postby ktbCA57 on Tue Jan 10, 2012 8:25 am

MARK.. thank you for posting this issue and for your suggestion of creating a new directory.. I was having exactly the same problem as you.. on top of which, bits of my formatting was screwed up... but after reading this thread, and trying your solution... i can now FINALLY build my chm AND my formatting issues seem to be resolved.

Sr. Propeller Head
Posts: 398
Joined: Wed Feb 04, 2009 7:45 am

Re: CHM Builds but Won't Run/Open

Postby Skooter on Mon Feb 06, 2012 11:30 pm

This error raised its ugly head for me. I noticed this error disappeared when I selected another TOC.
So then I recreated a new TOC. After adding topics to the TOC one by one it failed after adding a topic -
Narrowed it down to two topics that failed - they both had a <h2 class="PageBreakBefore"> entry on the first line of the topic.
(I would have set them when creating a print traget) Set them to <h2> and no longer had a problem.
Why this causes a problem I have no idea! If anyone can explain why I'd appreciate it. :)
Someone's boring me. I think it's me.
Propeller Head
Posts: 68
Joined: Thu Aug 23, 2007 9:32 pm
Location: Perth, Western Australia

Re: CHM Builds but Won't Run/Open

Postby RamonS on Tue Feb 07, 2012 6:25 am

Looks like a bug to me. Please report here:
Senior Propellus Maximus
Posts: 4286
Joined: Thu Feb 02, 2006 9:29 am
Location: The Electric City

Re: CHM Builds but Won't Run/Open

Postby tech_ninja on Thu Feb 15, 2018 5:03 am

Hello! Has anyone run into this again recently?

I'm running Flare 2017 r3 and I've come across this exact same issue. A colleague builds the Help and his formatting is all over the place, especially indents on lists. I build the Help and the first time, it builds and the formatting is fine, if I rebuild, the chm doubles in size and the CHM won't open.

I've tried the above methods but it isn't possible to change the location as the files are checked into source control (and will eventually be built from an autobuild). If I check out all of the files from source control I get the same thing, the first time it builds, after the first time, it will rebuild but the file is clearly wrong.

Thanks in advance.
Jr. Propeller Head
Posts: 1
Joined: Tue Feb 13, 2018 2:12 am

Return to Microsoft CHM Help

Who is online

Users browsing this forum: No registered users and 2 guests