Search in the form of questions not working

This forum is for all Flare issues related to the HTML5, WebHelp, WebHelp Plus, and Adobe Air Targets

Search in the form of questions not working

Postby parsonsv on Fri Feb 08, 2019 11:39 am

If a user searches for the following in the HTML5 help output, they get a number of results:

print a document

However, if they write it as a question, they get zero results:

how do I print a document

What is the trick to enable results when a user phrases their search in the form of a question?
parsonsv
Propeller Head
 
Posts: 85
Joined: Fri Mar 23, 2007 12:30 pm

Re: Search in the form of questions not working

Postby SKamprowski on Mon Feb 11, 2019 7:03 am

Hello,

I assume it depends on type of your target. Please look whether you find a way to define a list of stop words.
Kind regards,
Sabine Kamprowski
DocToHelp MVP
SKamprowski
Sr. Propeller Head
 
Posts: 237
Joined: Fri Feb 13, 2015 8:25 am
Location: Germany

Re: Search in the form of questions not working

Postby Dave Lee on Wed Feb 13, 2019 1:33 am

MadCap's search will only show topics in the results that include all words (like a boolean 'and').

By default, the search doesn't include "stop words" (common words), so "do" and "I" would be ignored.
However, "how" isn't a stop word, so I presume your topic doesn't include that word.
https://help.madcapsoftware.com/flare20 ... -Words.htm

If people use natural language in MadCap's search (like they would in Google), then they'll probably get poorer results. In my projects, I use a custom search results page which includes tips on how best to use the search.
Dave Lee
Master Propellus Maximus
 
Posts: 5535
Joined: Mon Mar 05, 2007 8:33 am
Location: UK

Re: Search in the form of questions not working

Postby parsonsv on Thu Feb 28, 2019 12:44 pm

Ahhhh, I see. Do you know if there's a way to add "stop words" to Flare's list of stop words?
parsonsv
Propeller Head
 
Posts: 85
Joined: Fri Mar 23, 2007 12:30 pm

Re: Search in the form of questions not working

Postby Dave Lee on Fri Mar 01, 2019 12:21 am

Yep, it tells you how to add stop words in the help topic I linked to.
Dave Lee
Master Propellus Maximus
 
Posts: 5535
Joined: Mon Mar 05, 2007 8:33 am
Location: UK

Re: Search in the form of questions not working

Postby parsonsv on Thu Mar 07, 2019 2:20 pm

Dave Lee wrote:Yep, it tells you how to add stop words in the help topic I linked to.


I'm sorry - I totally missed that when I was scanning the replies! Thank you very much. Looks like it's a language skin, so I could set up my new stop words and then add them to the master project to share with all the projects.

Time to experiment!
parsonsv
Propeller Head
 
Posts: 85
Joined: Fri Mar 23, 2007 12:30 pm

Re: Search in the form of questions not working

Postby parsonsv on Thu Mar 07, 2019 3:38 pm

Oh no! I followed all the instructions, and then when I expanded the note at the very bottom of the help topic, it said:

NOTE: Stop words are not customizable in HTML5 outputs.
parsonsv
Propeller Head
 
Posts: 85
Joined: Fri Mar 23, 2007 12:30 pm

Re: Search in the form of questions not working

Postby Dave Lee on Fri Mar 08, 2019 12:48 am

Sorry about that - I knew in the back of my mind that this functionality existed, but didn't realise it doesn't work for any 'current' help outputs. (DotNetHelp is already dead, and I'm sure WebHelp will be dead soon.)
Dave Lee
Master Propellus Maximus
 
Posts: 5535
Joined: Mon Mar 05, 2007 8:33 am
Location: UK

Re: Search in the form of questions not working

Postby parsonsv on Fri Mar 08, 2019 10:17 am

Dave Lee wrote:Sorry about that - I knew in the back of my mind that this functionality existed, but didn't realise it doesn't work for any 'current' help outputs. (DotNetHelp is already dead, and I'm sure WebHelp will be dead soon.)

No problem - I'm sure they'll catch up some day :(
parsonsv
Propeller Head
 
Posts: 85
Joined: Fri Mar 23, 2007 12:30 pm


Return to Web-based Outputs

Who is online

Users browsing this forum: No registered users and 4 guests

cron