mp4 video source not found in html5

This forum is for all Flare issues related to the HTML5, WebHelp, WebHelp Plus, and Adobe Air Targets

mp4 video source not found in html5

Postby LMTechWRiter on Thu Mar 20, 2014 11:56 am

I am working on a project in flare with HTML5. I have run into an issue with viewing mp4 embedded videos. I'm publishing to an Azure site and can't see the videos in IE or Chrome. In IE I'm getting an invalid source error, but I can see the mp4 file. Madcap support said this is out of their realm upon learning that I am not working with Mimic. Anyone else having issues with their videos playing? I can see it in the preview, but both source codes (Chrome/IE) says it can't find the source of the video. I'm desperate. My supervisors will not authorize buying additional software just to make this work (as they shouldn't need to).
LMTechWRiter
Jr. Propeller Head
 
Posts: 1
Joined: Thu Mar 20, 2014 11:47 am

Re: mp4 video source not found in html5

Postby smajors on Fri Sep 30, 2016 8:05 am

Hello, did you ever resolve this? I'm having similar issues.
Technical Writer
Training & Development Team/Marketing Department
smajors
Sr. Propeller Head
 
Posts: 180
Joined: Mon Oct 21, 2013 9:28 am
Location: Midwest United States

Re: mp4 video source not found in html5

Postby moshe on Wed Sep 04, 2019 5:42 am

I'm also having such a problem.
I'm inserting mp4 video using Insert > Multimedia > HTML5 Movie. The videos in the local HTML output display properly. However, when uploaded (using the WinSCP ftp client) to an azurewebsites.net site, the videos are not displayed in the browser (I tried Chrome, Firefox, and Opera).
The mp4 videos are in the proper site location as referenced by the output HTML.
Moshe Davis
Jerusalem, Israel
moshe
Propeller Head
 
Posts: 36
Joined: Tue Apr 05, 2016 10:10 pm
Location: Jerusalem, Israel

Re: mp4 video source not found in html5

Postby Dave Lee on Wed Sep 04, 2019 5:52 am

Can you actually view the mp4 file directly using a browser? So if you enter the URL to the mp4 file, does it open ok in the browser?

That'll tell you whether the problem is with your server, rather than Flare.
Dave Lee
Master Propellus Maximus
 
Posts: 5675
Joined: Mon Mar 05, 2007 8:33 am
Location: UK

Re: mp4 video source not found in html5

Postby moshe on Wed Sep 04, 2019 5:59 am

If I right-click on the <video> in the online output, select Copy Video Location, and paste that into a new browser tab, I get an error message "The resource you are looking for has been removed, had its name changed, or is temporarily unavailable."
If I navigate the site using the ftp client, I see the videos in the proper locations as referenced in the output HTML. I can view the videos from there.
Last edited by moshe on Wed Sep 04, 2019 6:06 am, edited 1 time in total.
Moshe Davis
Jerusalem, Israel
moshe
Propeller Head
 
Posts: 36
Joined: Tue Apr 05, 2016 10:10 pm
Location: Jerusalem, Israel

Re: mp4 video source not found in html5

Postby Dave Lee on Wed Sep 04, 2019 7:30 am

Well, if you enter the video's URL in a browser (e.g. http://.../video.mp4), and that doesn't work, then you know the problem is with the server and nothing to do with Flare.

If that is the case, then you'd need to ask your server admin why you can't view mp4 files.
Dave Lee
Master Propellus Maximus
 
Posts: 5675
Joined: Mon Mar 05, 2007 8:33 am
Location: UK

Re: mp4 video source not found in html5

Postby moshe on Thu Sep 05, 2019 1:55 am

Yes, you are correct, Dave. It was a problem with the server, which is now solved. Thanks again, as always!

Even though the issue turned out not to directly be a Flare problem, for the sake of other Flare users who have/will run into this problem (it seems that I'm not the first), the solution was to add mp4 to the collection of static content types for the server. This was accomplished in our case simply by adding a web.config XML file to the root directory of the site. I just have to be careful not to overwrite or delete the web.config file when I update the site content.

The web.config file adds a
Code: Select all
<mimeMap fileExtension=".mp4" mimeType="video/mp4" />
entry to the <staticContent> element of the server configuration. The details will probably depend on individual server setup, so anyone having such a problem should contact your own server admin, as Dave directed.
Moshe Davis
Jerusalem, Israel
moshe
Propeller Head
 
Posts: 36
Joined: Tue Apr 05, 2016 10:10 pm
Location: Jerusalem, Israel


Return to Web-based Outputs

Who is online

Users browsing this forum: No registered users and 4 guests