HTML5 skin works in Flare 10 does not preview in Flare 12

This forum is for all Flare issues related to the HTML5, WebHelp, WebHelp Plus, and Adobe Air Targets

HTML5 skin works in Flare 10 does not preview in Flare 12

Postby JohnA on Tue Apr 19, 2016 1:51 am

Hi,

I recently upgraded to Flare 12 from Flare 10 and when trying to preview the HTML5 skin we're using in Flare 12 the following error is returned:

Failed to generate preview output [The given path's format is not supported.]

Has anyone else seen this and know what the cause and solution is?

Thanks.
Last edited by JohnA on Tue Apr 19, 2016 12:38 pm, edited 1 time in total.
JohnA
Jr. Propeller Head
 
Posts: 9
Joined: Mon Oct 13, 2008 4:37 am

Re: HTML5 skin tworks in Flare 10 does not preview in Flare

Postby wclass on Tue Apr 19, 2016 5:47 am

A bit of a wild guess here but might be worth checking ...
Check that you have a primary target set.
I got some similar errors (but can't remember the exact wording) after I opened some zipped versions of projects and no primary target was set. Fixed the problem by selecting one target to be primary.
I have not been able to repeat the error.
Margaret Hassall - Melbourne
wclass
Propellus Maximus
 
Posts: 1231
Joined: Mon Feb 27, 2006 5:56 am
Location: Melbourne, Australia

Re: HTML5 skin tworks in Flare 10 does not preview in Flare

Postby JohnA on Tue Apr 19, 2016 12:37 pm

Thanks but I tried that and no luck. The project builds fine and opens but the search now stalls with the progress wheel spinning perpetually and I'm wondering if this is related to the skin. It worked fine in Flare 10 so there must be something in the Flare 10 skin that Flare 12 doesn't like.
JohnA
Jr. Propeller Head
 
Posts: 9
Joined: Mon Oct 13, 2008 4:37 am

Re: HTML5 skin works in Flare 10 does not preview in Flare 1

Postby Feebeegeebee on Wed Apr 20, 2016 7:59 am

Hi,
I've just seen this too in my main project which was recently upgraded from Flare 11 to Flare 12.
The project uses the HTML5 skin and I can't preview it via the HTML5 Skin Editor.

skin_preview_err_msg.png


I have the correct primary target set and the project appears to build OK and the search doesn't stall.

Anyone else any idea why this might be happening?

Regards,
Feebeegeebee
You do not have the required permissions to view the files attached to this post.
------------------------------------------------------
Using Flare 2019 on Windows 10 (64-bit)
------------------------------------------------------
Feebeegeebee
Sr. Propeller Head
 
Posts: 175
Joined: Wed Aug 08, 2012 8:38 am
Location: UK

Re: HTML5 skin works in Flare 10 does not preview in Flare 1

Postby ChoccieMuffin on Wed Apr 20, 2016 8:21 am

Don't know if this is any help, but I had a similar problem not being able to preview PDFs. The answer was to update my PDF viewer, so that it uses 64-bit rather than 32-bit. Don't know if there's a HTML5 viewer that's similar. If so, uninstall the one you currently have and reinstall a 64-bit version. [Disclaimer: I'm just guessing that there's a parallel way of previewing stuff, I could be completely wrong.]
Started as a newbie with Flare 6.1, now using Flare 2019r1.
Report bugs at http://www.madcapsoftware.com/bugs/submit.aspx.
Request features at https://www.madcapsoftware.com/feedback ... quest.aspx
ChoccieMuffin
Senior Propellus Maximus
 
Posts: 2224
Joined: Wed Apr 14, 2010 8:01 am
Location: Surrey, UK

Re: HTML5 skin works in Flare 10 does not preview in Flare 1

Postby Nick A on Thu Dec 19, 2019 3:19 am

I had this message too, and the reason was quite simple. One of my variables, called DocumentTitleMain, was defined using a colon:

Great Product: OEM Versions

That variable is used in the definition of another variable called PDFOutputFileName (defined as [%=Variables.PartNumber%] - [%=Variables.DocumentTitleMain%]) which I use in my PDF target's Output File field. Consequently, Flare was trying to create a PDF file name that included a colon, which is not allowed by the operating system, e.g. "C:\Project\Output\username\PDF\PRT9999 - Great Product: OEM Versions.pdf".

A different build error, something like "Build Failed: ... Path name is incomplete" occurs if the PDF output file name attempts to include other illegal characters such as \ or /.

It would be preferable if Flare could test for this mistake and display a more useful error message, before trying to build the file!
Nick A
Propeller Head
 
Posts: 12
Joined: Thu Sep 20, 2018 1:10 am


Return to Web-based Outputs

Who is online

Users browsing this forum: No registered users and 3 guests