Side navigation TOC behaviour inconsistent

This forum is for all Flare issues related to the HTML5, WebHelp, WebHelp Plus, and Adobe Air Targets

Side navigation TOC behaviour inconsistent

Postby blackline on Mon Jul 09, 2018 8:52 pm

Hi everyone,

I'm running Flare 2018 and am currently experimenting with the new HTML5 side navigation skin. My problem relates to differences I'm seeing in the side navigation TOC in the HTML5 output:

-- For the Web medium, the TOC entries all display as expected. And clicking a bold Level 1 'book' entry expands the category and also opens the linked topic (see example in Pic 1).

-- For Tablet and Mobile, Flare is adding a copy of every bold Level 1 'book' entry immediately below it, and it looks/behaves like an extra topic. Also, clicking a Level 1 entry only expands the category; it doesn't also open the linked topic (see example in Pic 2).

Other background info (in case it helps):
-- In my TOC file in Flare I renamed the Level 1 entry sample to include 'xxxxxxxxxxxxx' just so it was obvious where the text was coming from.
-- My Level 1 entries in my TOC file are each linked to an 'About ... ' topic (such as 'About distribution lists'). And the 'About ...' topics are also in the TOC file as standalone entries. (Yes, I'm aware that means they're linked twice.) But even when I remove an 'About ...' topic from the TOC file so there's only a link to it from the Level 1 entry, the display problem remains.

Why is Flare duplicating the Level 1 entry in the Tablet/Mobile TOC view while the Web TOC is fine? Any suggestions? Buggy behaviour?

Thanks,
Elizabeth
You do not have the required permissions to view the files attached to this post.
blackline
Jr. Propeller Head
 
Posts: 9
Joined: Wed Jan 14, 2015 3:06 pm

Re: Side navigation TOC behaviour inconsistent

Postby Jeanne_W on Fri Oct 05, 2018 9:29 am

I'm having the same issue and just opened a support ticket. Apparently this is the behavior in top navigation layout, where the 1st-level heading only opens up the menu and doesn't link anywhere. What's weird is that the TOC pane in a wide window displays as expected. It's only the tree slide-out menu in tablet and mobile mode that's affected. I'm waiting to hear back from MadCap. This should be configurable! Sorry I'm not more helpful at this point.

-Jeanne
Jeanne_W
Propeller Head
 
Posts: 13
Joined: Mon Jun 27, 2016 11:50 pm

Re: Side navigation TOC behaviour inconsistent

Postby Psider on Sun Oct 07, 2018 5:13 pm

I think it's this way because on a phone you typically wouldn't have the help display next to the toc menu. You'd only see the TOC taking up the whole screen, therefore you can't have the expando link directly to a topic, or you'd never be able to get to the sub-topics. (But I hate that behaviour on tablets where there's typically enough space to show at least part of the topic).
Psider
Propellus Maximus
 
Posts: 598
Joined: Wed Jul 06, 2011 1:32 am

Re: Side navigation TOC behaviour inconsistent

Postby arkana on Tue Apr 23, 2019 11:23 pm

Hi Elizabeth,

Have you found a workaround for this? I also have this problem.
Arthur Cui
Flare 2019
arkana
Propeller Head
 
Posts: 22
Joined: Wed Mar 14, 2018 11:10 pm


Return to Web-based Outputs

Who is online

Users browsing this forum: No registered users and 3 guests