Linking to TOC subheads jumps browser to top of page instead

This forum is for all Flare issues related to the HTML5, WebHelp, WebHelp Plus, and Adobe Air Targets

Linking to TOC subheads jumps browser to top of page instead

Postby RandyMan on Wed Feb 13, 2019 3:56 pm

I'm using HTML SideView Nav layout. Consider the following TOC structure: Each "Topic" pertains to a new page/new file; all subtopics pertain to H2 to H5 headings on that respective Topic page. The TOC settings are set to automatically build the subtopics (in the TOC) for that page:
Topic A
    Subtopic A1
    Subtopic A2
    Subtopic A3
    Subtopic A4
Topic B
    Subtopic B1
    Subtopic B2
    Subtopic B3
    Subtopic B4

Everything looks fine when I build and publish the files. Everything also works fine. When you click on (for example) Subtopic B3, the page autoloads/scrolls to the H2 heading on that page that contains that content.

The problems start when I share the URL of that Subtopic B3 in an email or when I point (in the Insert Hyperlink dialog in Madcap) to the H2 heading for Subtopic B3. The browser will open the page requested, then autoload/scroll to the H2 anchor, and then....wait for it....jump back to the top of the page! WTH!

This appears to have started only recently (it didn't behave like this at the end of 2018). Not sure if someone on my team changed a setting or tweaked something, but don't believe so. This happens on Chrome and Safari - our users' primary browsers, but I don't believe it is browser related either. I've search the forums/PDFs for related issues, but found nothing. Any help/ideas will be greatly appreciated!
RandyMan
Propeller Head
 
Posts: 11
Joined: Tue Feb 13, 2018 9:05 am

Re: Linking to TOC subheads jumps browser to top of page ins

Postby Louise Bennett on Wed Feb 13, 2019 8:13 pm

I saw this happen recently in some topics from another team that we were incorporating into our master help project. The exact behavior was only happening in their topics. When I looked at the HTML, their topics had inbuilt TOC markers at the beginning of each topic, whereas ours didn't. When I removed those markers, the problem was solved.

I am not sure why they had the markers there in the first place, but I suspect they were a hangover from importing the content from MS Word.

Louise.
Louise Bennett
Propeller Head
 
Posts: 65
Joined: Mon Apr 04, 2016 7:53 pm

Re: Linking to TOC subheads jumps browser to top of page ins

Postby RandyMan on Thu Feb 14, 2019 8:31 am

Thank you very much for the suggestion, but the MSWord "hangover" can't be blamed in this set of docs. We drank lots of water before going to bed (building the project). :P
RandyMan
Propeller Head
 
Posts: 11
Joined: Tue Feb 13, 2018 9:05 am

Re: Linking to TOC subheads jumps browser to top of page ins

Postby whunter on Thu Feb 14, 2019 9:59 am

I reported this behavior to MadCap and they logged bug 145810.
For me, reverting back to Flare 2018 (not r2) resolved the issue. YMMV.

***
I should clarify, for me the issue occurred with cross-references in topics, to bookmarks within other topics. Not from the TOC.
whunter
Sr. Propeller Head
 
Posts: 429
Joined: Thu Mar 12, 2009 4:49 pm
Location: Portland, OR

Re: Linking to TOC subheads jumps browser to top of page ins

Postby RandyMan on Thu Feb 14, 2019 10:12 am

Thanks whunter! I was concerned the problem was systemic (not user-based). To confirm, the listings in the TOC work absolutely fine - as intended. It's cross-linking from other pages and URL extraction to email when the jump-to-top behavior occurs.

Would love to hear from the Madcap Team for an ETA until resolution. This is a serious problem for a website with THOUSANDS of pages. Really....anyone from Madcap care to reply?

Reverting to a previous version gives me pause...too risky IMO.

Thanks again whunter!

Randy
RandyMan
Propeller Head
 
Posts: 11
Joined: Tue Feb 13, 2018 9:05 am

Re: Linking to TOC subheads jumps browser to top of page ins

Postby mattf on Thu Feb 21, 2019 7:30 pm

There's a similar and perhaps related issue where you click in the side nav on a level 2 TOC item and go to that heading in a topic, but then if you click again on that same TOC item, it jumps to the top. I heard from a user (who heard from a user, etc.) that Madcap told them they weren't planning on fixing this very soon. Here's the quote I was sent:

"This is a bug in Flare since 2017 r3. I contacted support about it last week. They basically said they aren't going to fix it anytime soon. And they suggested using the Top Nav instead."
Matt F
You learn something new every day if you're not careful.
mattf
Sr. Propeller Head
 
Posts: 277
Joined: Thu Feb 09, 2006 5:35 pm
Location: Next to the window

Re: Linking to TOC subheads jumps browser to top of page ins

Postby RandyMan on Fri Feb 22, 2019 5:45 am

Thanks MattF. Nice to know they're staying on top of things. Not...
RandyMan
Propeller Head
 
Posts: 11
Joined: Tue Feb 13, 2018 9:05 am


Return to Web-based Outputs

Who is online

Users browsing this forum: saladflambe and 5 guests