Google Analytics stopped logging Events from topic feedback

This forum is for all Flare issues related to the HTML5, WebHelp, WebHelp Plus, and Adobe Air Targets

Google Analytics stopped logging Events from topic feedback

Postby bunnycat on Tue Jul 09, 2019 5:17 am

I've had Google Analytics set up for months/years on our documentation portals built with Flare Top Nav templates.

Was working fine, collecting site search data and all the general data, plus the data from our topic Feedback mechanism ("Was this topic helpful?", Yes/No, send us an email)

Recently noticed a blip in Google Analytics - even though the feedback code was working correctly (buttons were working, email was created with subject/body filled in correctly) - the Analytics side stopped logging any Events for the Yes/No button pushes coming from our topics.

I verified that the feedback javascript code was still working, and that the Gtag code was still the same (it was). Figured that maybe GA changed its code format like they did in August 2017 when they flipped from ga to gtag.

I tested from local Flare targets previewed in all the browsers, tested from an internal server publish destination and our production servers destination. Topic feedback code itself worked as expected.

Viewing the GA Events dashboard for today - It looks like my testing "primed the pump" and it started working again - no code changes. I saw Events results from all of my corresponding local, internal and production servers for today, but of course zero historic information in the Events dashboard for previous days.

Wanted to let folks know that weirdness was occurring with GA Events recently, in case you were viewing, and saw no results in Events for a while. It's really hard to diagnose, since it's attempting to verify a negative/lack of results.
bunnycat
Propeller Head
 
Posts: 62
Joined: Tue Nov 03, 2015 6:44 am

Return to Web-based Outputs

Who is online

Users browsing this forum: No registered users and 11 guests

cron