"Old" favicon still appearing

This forum is for all Flare issues related to the HTML5, WebHelp, WebHelp Plus, and Adobe Air Targets

"Old" favicon still appearing

Postby carmonli on Thu Nov 07, 2019 2:02 am

Our company has been bought out by another company and of course there is rebranding of the documentation that needs to be done. We have a Templates project that I've updated and the new favicon appears correctly when I build an HTML5 target.

In two of the company's Flare projects, I've imported files from the Templates project and the HTML 5 project shows the correct favicon after building.

In two other Flare projects, the old favicon is still appearing, even though the old file no longer exists anywhere that I can see/find. When I open the Favicon skin, in the UI it is pointing to the correct, new file.

I've told the import file to delete stale files. I've deleted the images cache in Chrome. I don't know what else to try. Any ideas about where I should be looking?
carmonli
Propeller Head
 
Posts: 29
Joined: Mon Jan 27, 2014 11:04 pm

Re: "Old" favicon still appearing

Postby zappy0 on Mon Nov 11, 2019 3:57 pm

In the two troublesome Flare projects, have you verified the Target file is referencing the correct Favicon skin file? This would be on the Skin "tab" - there is a Skin in the General area and a Favicon in the Component Default Skins.
Last edited by zappy0 on Tue Nov 12, 2019 5:22 pm, edited 1 time in total.
zappy0
Propeller Head
 
Posts: 14
Joined: Fri Mar 25, 2016 2:19 pm

Re: "Old" favicon still appearing

Postby doloremipsum on Tue Nov 12, 2019 5:19 pm

As I discovered when starting to look at HTML after a long time of only creating PDFs, skins are weird!

Essentially when you put an image in a skin (whether a full skin or Favicons or w/e) it doesn't actually create a link to the image. What it does store the image as code within the skin xml. Open the skin as text and you should see for yourself.

This means that updating the image in the filesystem won't update it in the skin - you have to upload it again as a new image. I believe that there's a setting that tells the skin to delete images that are not being used but I can't remember it right now. To ensure that the old image is deleted, remove that code from the xml.
neque porro quisquam est qui dolorem ipsum quia dolor sit amet, consectetur, adipisci velit - sed saepe cum dolor apud multos callidos mutuetur, reduci potest.
doloremipsum
Propeller Head
 
Posts: 69
Joined: Mon Aug 26, 2019 2:11 pm

Re: "Old" favicon still appearing

Postby Feebeegeebee on Wed Nov 13, 2019 2:53 am

doloremipsum wrote:I believe that there's a setting that tells the skin to delete images that are not being used


In the Skin Editor, on the General tab, there is the option Unreferenced Images > Remove on Save. You should enable that.

Regards,
Feebeegeebee
------------------------------------------------------
Using Flare 2019 on Windows 10 (64-bit)
------------------------------------------------------
Feebeegeebee
Sr. Propeller Head
 
Posts: 175
Joined: Wed Aug 08, 2012 8:38 am
Location: UK


Return to Web-based Outputs

Who is online

Users browsing this forum: No registered users and 4 guests