Back and Forward Buttons Don't Work

This forum is for all Flare issues related to the HTML5, WebHelp, WebHelp Plus, and Adobe Air Targets

Back and Forward Buttons Don't Work

Postby amitkapoor on Sun Nov 17, 2019 11:19 pm

Hi,

I am trying this in Flare 2019 r2. I used the default project with SideNav skin and HTML5 output. I did this:
1. I add a topic toolbar proxy to Master Page and enable Back & Forward buttons. There is no skin selected in the options and custom style applied to the topic toolbar. I get nothing in the output and this is in the HTML code. As you can see, I didn't add any script or code for the buttons.
Code: Select all
<div class="buttons popup-container clearfix topicToolbarProxy topicToolbarProxytoolbarbuttons mc-component nocontent" style="mc-topic-toolbar-items: Back Forward;"></div>


2. Now, I added a topic toolbar skin. Added custom Back and Forward buttons. Added the following code:
Code: Select all
function goBack()
{
   window.history.back();
};

function goForward()
{
   window.history.forward();
};

In the onclick field under Topic Toolbar Skin Style for these two, I specified goBack(); and goForward(); for the two buttons.

3. In the Topic Toolbar proxy, I choose this skin and let the two buttons Back and Forward stay. This step seems optional.

4. I generate the help, I get this and it works in Firefox and Chrome. The blank buttons are for Back and Forward button. Sorry that they dont have proper icon on them yet.

backf.jpg


This works fine but not in Electron. If I use the Tripane theme, the buttons work even in Electron! What am I doing wrong? What is the difference between what I am doing and what happens in the Tripane theme?

I have spent hours and hours but in vain.
You do not have the required permissions to view the files attached to this post.
Last edited by amitkapoor on Tue Nov 19, 2019 9:11 am, edited 2 times in total.
amitkapoor
Propeller Head
 
Posts: 16
Joined: Mon Sep 16, 2019 5:23 am

Re: Back and Forward Buttons Don't Work

Postby amitkapoor on Mon Nov 18, 2019 9:40 am

Nita - would you know?

Can anyone help?
amitkapoor
Propeller Head
 
Posts: 16
Joined: Mon Sep 16, 2019 5:23 am

Re: Back and Forward Buttons Don't Work

Postby amitkapoor on Mon Nov 18, 2019 7:05 pm

Flare Tech Support is telling me to do what I have already done. So I am stuck now. The buttons work in browser only unlike TriPane where they work both in Browser and Electron. :?
amitkapoor
Propeller Head
 
Posts: 16
Joined: Mon Sep 16, 2019 5:23 am


Return to Web-based Outputs

Who is online

Users browsing this forum: No registered users and 2 guests