Search input placeholder text in output does not match skin

This forum is for all Flare issues related to the HTML5, WebHelp, WebHelp Plus, and Adobe Air Targets

Search input placeholder text in output does not match skin

Postby Meligator on Wed Dec 04, 2019 2:56 pm

On the UI Text tab of my HTML 5 skin, I have entered the placeholder text I want to use in the Search Input Placeholder value field. But when I generate my HTML 5 output, it doesn't use that text. The placeholder text is just "Search."

I opened the skin file in a text editor and verified that my text is there:
<Style
Name="Search Input">
<Properties>
<Property
Name="BackgroundColor">#ffffff</Property>
<Property
Name="Accessibility Label">Search companyName help</Property>
<Property
Name="Placeholder">Search companyName help</Property>
</Properties>
</Style>

When I inspect the placeholder text in the browser, I can see that the placeholder text is defined by the class "search-field needs-pie":

<div class="search-bar search-bar-container needs-pie">
<input class="search-field needs-pie" type="search" aria-label="Search Field" placeholder="Search">

How can I get Flare to use the text I entered in the skin? (And just to note, I tried clearing my browser cache but that didn't fix the problem.)

Thanks!
Meligator
Jr. Propeller Head
 
Posts: 5
Joined: Thu Jun 13, 2019 5:04 pm

Re: Search input placeholder text in output does not match s

Postby Dave Lee on Thu Dec 05, 2019 12:58 am

I'd check the basics - apologies if you've already done this!

- Does your target have the correct skin selected?
- When you edited the placeholder text in the skin, was it for the same language that's being used by the target?
- Are you testing the right search box? You can have a search input in the main skin, and also in a skin used by a search bar proxy.
Dave Lee
Master Propellus Maximus
 
Posts: 5821
Joined: Mon Mar 05, 2007 8:33 am
Location: UK

Re: Search input placeholder text in output does not match s

Postby Meligator on Thu Dec 05, 2019 9:27 am

Thanks for the suggestions, Dave. It never hurts to start with the basics! But yes, I verified that the target has the right skin selected, and the language is the same. We do have two search boxes, and I have the same problem with the main skin and the search bar proxy that we use on the home page.

All of the changes that I made on the Styles tab of the skin show up correctly in the output. But no changes to UI Text show up in the output. I tried changing the Search Heading as well, but heading in the output is still the default.
Meligator
Jr. Propeller Head
 
Posts: 5
Joined: Thu Jun 13, 2019 5:04 pm

Re: Search input placeholder text in output does not match s

Postby Meligator on Thu Dec 05, 2019 2:20 pm

The problem seems to be resolved.
When I initially checked to see if the languages matched in my skin and target, the language field for the target said:
(default) [English (United States)]

So I assumed that it was pulling the default from the project. Both the skin and target said English (United States), so that seemed like a match to me. But after seeing an older post on a similar issue, I decided to check my project language setting and it was just default. (Perhaps the default for the computer?) Anyway, setting this explicitly to English (United States) has fixed my problem.
Meligator
Jr. Propeller Head
 
Posts: 5
Joined: Thu Jun 13, 2019 5:04 pm


Return to Web-based Outputs

Who is online

Users browsing this forum: No registered users and 11 guests

cron