Search causing crash in Mac App

This forum is for all Flare issues related to the HTML5, WebHelp, WebHelp Plus, and Adobe Air Targets

Search causing crash in Mac App

Postby sleeves on Thu Apr 24, 2008 4:44 am

We have included a webhelp file in a Mac app. Despite the file appearing to work fine in web browsers on both Windows and Mac, when embedded in the app and using a search it throws a number of errors.
The first error was apparently due to a missing filters.xml file. Despite not specifying any filters, the search still needs to have this file so this was easily remedied by creating an empty filter set.
The second error appears to be caused by Flare wanting to contact the feedbackserver. I have checked my project and Enable Feedback Service is definitely turned off. When viewing the help file in Safari with the Activity window turned on you can see that the search.htm file tries to contact the following address:
http://feedbackserver.madcapsoftware.co ... 9035812761
This is something to do with the MadCapLiveHelpUtilities.js file. Is there some stuff I can comment out in that file to stop it trying to access the server?
---
One further note - when accessing the file from the Mac help viewer and then doing a search for an item it returns the correct page with a "Open topic with navigation" link - clicking this link attempts to open the default_csh.htm page with the relevant pages after the hash, e.g. file:///Applications/myApp.app/Contents/Resources/ApplicationHelp/Default_CSH.htm#Build\Build%20the%20Output.htm
This page attempts to load the frameset and then bombs out to the message:
Code: Select all
Internet connection required
The help topic you’re opening requires an Internet connection. Choose Apple > System Preferences, and then click Network to check your network settings and, if necessary, connect to the Internet.
Last edited by sleeves on Thu Apr 24, 2008 7:40 am, edited 1 time in total.
sleeves
Propeller Head
 
Posts: 13
Joined: Wed Sep 19, 2007 9:39 am

Re: Search causing crash in Mac App

Postby KevinDAmery on Thu Apr 24, 2008 7:40 am

Are you making WebHelp or WebHelp Plus? If you're making Plus, you might want to try just plain ole WebHelp and see if it behaves better.
Until next time....
Image
Kevin Amery
Certified MAD for Flare
KevinDAmery
Propellus Maximus
 
Posts: 1985
Joined: Tue Jan 23, 2007 8:18 am
Location: Darn, I knew I was around here somewhere...

Re: Search causing crash in Mac App

Postby sleeves on Thu Apr 24, 2008 7:41 am

plain old web help
sleeves
Propeller Head
 
Posts: 13
Joined: Wed Sep 19, 2007 9:39 am

Re: Search causing crash in Mac App

Postby LTinker68 on Thu Apr 24, 2008 8:20 am

sleeves wrote:One further note - when accessing the file from the Mac help viewer and then doing a search for an item it returns the correct page with a "Open topic with navigation" link - clicking this link attempts to open the default_csh.htm page with the relevant pages after the hash, e.g. file:///Applications/myApp.app/Contents/Resources/ApplicationHelp/Default_CSH.htm#Build\Build%20the%20Output.htm
This page attempts to load the frameset and then bombs out to the message:
Code: Select all
Internet connection required
The help topic you’re opening requires an Internet connection. Choose Apple > System Preferences, and then click Network to check your network settings and, if necessary, connect to the Internet.


I can't speak to the other errors, but this one came up recently. Well, not that error, but the fact that the "Open topic with navigation" link doesn't work if you're using the ApplicationHelp template when you create the Flare project. When I submitted a bug report about that, I got a message that it has been fixed in Flare v4.

In the meantime, you don't get that error if you use the "Empty" template when you create a project. You might be able to create a new "empty" project, copy the default.htm and default_csh.htm files and paste them into your current project, then rename them to ApplicationHelp.htm and ApplicationHelp_CSH.htm, then rebuild the project. (Copy the original .htm files before doing this, so that you can go back, if necessary.) I'm not sure where the error is, but if it's in one of those files, then this might make it work in the interim.
Image

Lisa
Eagles may soar, but weasels aren't sucked into jet engines.
Warning! Loose nut behind the keyboard.
LTinker68
Master Propellus Maximus
 
Posts: 7245
Joined: Thu Feb 16, 2006 9:38 pm

Re: Search causing crash in Mac App

Postby sleeves on Thu Apr 24, 2008 8:48 am

Thanks Lisa - I think you've spotted the error. I've tried creating a new project using both the Application Help template and the Empty template, and the Application one throws an error.
Unfortunately the Empty template project throws up a new error - if you build it and then try using a Search the 'found' file includes the 'Open topic with navigation' link which then opens up the full frameset within the right-hand window - you can then repeat the process to include a frameset nested within a frameset nested within a frameset :-) Absolutely no use as a help system but briefly amusing :)
You would think that the basic out-of-the-box templates would work correctly, but there you go.
sleeves
Propeller Head
 
Posts: 13
Joined: Wed Sep 19, 2007 9:39 am

Re: Search causing crash in Mac App

Postby LTinker68 on Thu Apr 24, 2008 10:29 am

sleeves wrote:You would think that the basic out-of-the-box templates would work correctly, but there you go.

The "Open topic with navigation" option was added in v2.x, I believe (maybe v3.x), so it's possible they just missed double-checking their templates.

I'm curious about the comment you made about searching. Are you saying if you start with a topic without the navigation pane and then click the "Open topic with navigation" link, that when you then search from the accordion button, the found topics are still showing up with the "Open topic with navigation" link in them? Because I just tested that and it didn't happen for me. When I clicked on the "Open topic with navigation" link, the topic opened up in the tri-pane window but without the "Open topic with navigation" link. When I did a search and clicked on the resulting topic, the found topic also didn't have the "Open topic with navigation" link. So I can't reproduce that bug.
Image

Lisa
Eagles may soar, but weasels aren't sucked into jet engines.
Warning! Loose nut behind the keyboard.
LTinker68
Master Propellus Maximus
 
Posts: 7245
Joined: Thu Feb 16, 2006 9:38 pm

Re: Search causing crash in Mac App

Postby sleeves on Thu Apr 24, 2008 12:54 pm

This what I mean. It is just a build of the 'empty' project straight after creating it. Searching for 'topic' returns the Topic search item. Clicking it opens the Topic Title page. Clicking the 'Open topic with navigation' link opens up the whole frameset within the RH pane instead of returning to the whole frameset. You can then click Search within that frame and repeat the process so that it becomes nested.
You do not have the required permissions to view the files attached to this post.
sleeves
Propeller Head
 
Posts: 13
Joined: Wed Sep 19, 2007 9:39 am

Re: Search causing crash in Mac App

Postby LTinker68 on Thu Apr 24, 2008 4:31 pm

Hah! Now I can recreate it. It's because you searched on "topic", which is text that's in the "Open topic with navigation" link. If you search for a word that's not used in the phrase "Open topic with navigation", then the frameset inside a frameset doesn't happen. If you search on a word that is in that phrase, then it happens.

I'll submit this as a bug. I suggest you do the same. Submit the bug at http://www.madcapsoftware.com/bugs/submit.aspx.
Image

Lisa
Eagles may soar, but weasels aren't sucked into jet engines.
Warning! Loose nut behind the keyboard.
LTinker68
Master Propellus Maximus
 
Posts: 7245
Joined: Thu Feb 16, 2006 9:38 pm

Re: Search causing crash in Mac App

Postby sleeves on Fri Apr 25, 2008 1:54 am

Thanks Lisa you are a big help to a novice user.
sleeves
Propeller Head
 
Posts: 13
Joined: Wed Sep 19, 2007 9:39 am

Re: Search causing crash in Mac App

Postby RamonS on Fri Apr 25, 2008 5:18 am

She is even a big help to seasoned users. It is always good to have a Lisa in your pocket. :D
RamonS
Senior Propellus Maximus
 
Posts: 4291
Joined: Thu Feb 02, 2006 9:29 am
Location: The Electric City

Re: Search causing crash in Mac App

Postby sleeves on Fri Apr 25, 2008 8:58 am

Unfortunately I am not out of the woods yet, I have a project created using the empty template. The problem occurs when you open a file directly rather than via the standard frameset. You can include the 'Open topic with navigation' link, but this is linked to the default_csh.htm file (hover over the link to see) rather than the default.htm file - in fact there must be extra script in there that redirects it to the default_left.htm file.
Initially that looks okay - the TOC and everything is there, but when you click a TOC item it only loads the selected page rather than the page within the full frameset.
This would appear to be basic functionality and I can't believe that everyone else is living with it, so therefore it has got to be me doing something stupid. I can supply a small sample project if required.
This would seem to be the root cause of the problem when trying to use the help in the Mac app - except that it is less forgiving than IE or Fireworks. In fact if you try the same file in Safari and right-click to open a TOC link in a new tab it goes to a page entitled Recent Comments - which is nothing to do with the project and presumably is some script generated page.
Any help for this newbie is appreciated.
I'm going home with a headache!
sleeves
Propeller Head
 
Posts: 13
Joined: Wed Sep 19, 2007 9:39 am

Re: Search causing crash in Mac App

Postby LTinker68 on Fri Apr 25, 2008 11:25 am

Interesting. The same thing is happening for me, in FF and IE6. But we're not alone -- the same thing is happening on MadCap's knowledgebase. You can reproduce it if you go to http://kb.madcapsoftware.com, right-click on a topic and select the option to open it in a new tab or window, then click on the "Open topic with navigation" link, then once you're in the frameset, click on another topic in the TOC pane -- the whole window is replaced with the selected topic (you lose the frameset).

I don't remember this coming up before, but I don't use CSH that much, and even if I do, I launch it with the whole frameset. Does anyone remember this being a problem before, or is this a new bug?
Image

Lisa
Eagles may soar, but weasels aren't sucked into jet engines.
Warning! Loose nut behind the keyboard.
LTinker68
Master Propellus Maximus
 
Posts: 7245
Joined: Thu Feb 16, 2006 9:38 pm

Re: Search causing crash in Mac App

Postby Ryan Cerniglia on Fri Apr 25, 2008 12:50 pm

I've let the developers know about the issue with the disappearing frames - hopefully we can have a fix for at least the next version of Flare.
Ryan Cerniglia
 

Re: Search causing crash in Mac App

Postby sleeves on Mon Apr 28, 2008 2:20 am

If someone could identify a quick fix - even if it is only modifying the generated JavaScript - that would be really helpful because at the moment I have an application going out with a broken help system.

Cheers
sleeves
Propeller Head
 
Posts: 13
Joined: Wed Sep 19, 2007 9:39 am

Re: Search causing crash in Mac App

Postby sleeves on Thu Sep 18, 2008 7:31 am

Note this appears to be fixed in version 4.

Thanks :)
sleeves
Propeller Head
 
Posts: 13
Joined: Wed Sep 19, 2007 9:39 am


Return to Web-based Outputs

Who is online

Users browsing this forum: No registered users and 10 guests

cron