extra space in xrefs in WebHelp output

This forum is for all Flare issues related to the HTML5, WebHelp, WebHelp Plus, and Adobe Air Targets

extra space in xrefs in WebHelp output

Postby jjbroomco on Thu Jun 26, 2008 12:10 pm

Hi,
I wasn't sure whether to post in this forum or the Styles/XML forum, but here goes...

In WebHelp output, some of my xrefs (to other topics within my project) have an extra space immediately after the link. This behavior is inconsistent because other xrefs look fine in WebHelp. This inconsistency seems to be wherever I have an ending paragraph symbol ")"

Here's an example of how it appears in WebHelp (top) and XML code view (bottom):
wrong.gif


And here's another example that shows the xref correctly in WebHelp. Note the XML code is the same as before. I don't see any differences.
right.gif


I don't think this has anything to do with our stylesheet. Maybe it's a bug that I should report? Any help would be appreciated.
Thanks!

-Jason
You do not have the required permissions to view the files attached to this post.
jjbroomco
Propeller Head
 
Posts: 10
Joined: Thu May 22, 2008 1:46 pm

Re: extra space in xrefs in WebHelp output

Postby KevinDAmery on Thu Jun 26, 2008 12:25 pm

Jason,

The XML Editor's code view is... ahh, let's say "incomplete." (Meaning it barely shows you anything at all.) Take a look at the two cross references in an actual text editor (the internal one in Flare is fine, or another one of your choice) and see if there is any difference in the code.

(You can open the internal text editor by right clicking on the topic in the content explorer and choose "Open with")
Until next time....
Image
Kevin Amery
Certified MAD for Flare
KevinDAmery
Propellus Maximus
 
Posts: 1985
Joined: Tue Jan 23, 2007 8:18 am
Location: Darn, I knew I was around here somewhere...

Re: extra space in xrefs in WebHelp output

Postby jjbroomco on Thu Jun 26, 2008 1:15 pm

Well I'm about to publicly embarrass myself here...but I discovered the problem only happened when linking to a specific topic. So I opened that topic and found an extra space after the first heading. Problem solved. Thanks very much for your help though!
jjbroomco
Propeller Head
 
Posts: 10
Joined: Thu May 22, 2008 1:46 pm

Re: extra space in xrefs in WebHelp output

Postby KevinDAmery on Thu Jun 26, 2008 1:23 pm

No problem - those kind of issues aren't always easy to spot.
Until next time....
Image
Kevin Amery
Certified MAD for Flare
KevinDAmery
Propellus Maximus
 
Posts: 1985
Joined: Tue Jan 23, 2007 8:18 am
Location: Darn, I knew I was around here somewhere...


Return to Web-based Outputs

Who is online

Users browsing this forum: No registered users and 13 guests