Icon will not update

This forum is for all Flare issues related to the HTML5, WebHelp, WebHelp Plus, and Adobe Air Targets

Icon will not update

Postby Ineffable on Tue Jan 27, 2009 7:29 pm

No matter what I do, I cannot get the Delete Favorite Topics button to change to my custom button. The funny thing is that I use the same icon for the Delete Favorite Searches button and it works fine.

I have deleted all browser caches, all of the temporary files Flare creates when previewing a skin (the problem shows up with generated projects as well as previewed ones), and have searched my entire hard disk for my custom button file--the only place it is located is in my own Flare custom graphics directory.

In the Skin Editor, I select the Styles tab, then Control > TopicFavoritesDeleteButton. I then expand Basic and then click on the Icon selection. I then select the Browse for Image command, then add my custom button graphic from my custom graphics directory.

I do the same exact procedure for the SearchFavoritesDeleteButton, but for whatever reason that works just fine, and retains the custom graphic I load it up for it.

Another strange--and seemingly related--phenomenon is that after I preview/output the project, the Favorites/Search/TOC accordion frames revert back to a white background when I Refresh that frame. It also causes the custom SearchFavoritesDeleteButton to revert back to the default icon.

One potential explanation: This all happened when I upgraded to Flare v4SP1 today. But I have no idea how/why it would do that, especially when it's just the single Favorites accordion button and not both.
Ineffable
Sr. Propeller Head
 
Posts: 145
Joined: Mon Jan 15, 2007 3:08 pm
Location: morgan hill, ca

Re: Icon will not update

Postby Dave Lee on Wed Jan 28, 2009 7:56 am

You're not going mad, for some reason setting an icon for that button in the skin just doesn't work. It has been like that from the initial v4 release, which was the first time I tried to change it.
Dave Lee
Master Propellus Maximus
 
Posts: 5846
Joined: Mon Mar 05, 2007 8:33 am
Location: UK

Re: Icon will not update

Postby Ineffable on Wed Jan 28, 2009 9:51 am

Dave Lee wrote:You're not going mad, for some reason setting an icon for that button in the skin just doesn't work. It has been like that from the initial v4 release, which was the first time I tried to change it.


To "fix" this issue, I overwrote the files in the Output (Skin/Images folder) with my custom graphics. I also overwrote the original files Flare uses in the Flare.app/Resources/WebHelp/Default.flwht folder. (I changed the names of the original files to save them, just in case.)

Annoying bug that needs to be fixed soon. And judging from your response, I'm sure it's already been added to the feature/bug feedback page on their site.
Ineffable
Sr. Propeller Head
 
Posts: 145
Joined: Mon Jan 15, 2007 3:08 pm
Location: morgan hill, ca


Return to Web-based Outputs

Who is online

Users browsing this forum: No registered users and 10 guests

cron