Images do not display in WebHelp in IE

This forum is for all Flare issues related to the HTML5, WebHelp, WebHelp Plus, and Adobe Air Targets

Images do not display in WebHelp in IE

Postby ginawriter1 on Wed Feb 04, 2009 1:21 pm

The images in my WebHelp system are not displaying when the help is opened in Internet Explorer. These images display when the help is opened in Firefox.

Any help would be appreciated. I logged a support call last week and downloaded a project but have heard nothing.

Thanks!
ginawriter1
Jr. Propeller Head
 
Posts: 2
Joined: Tue Feb 03, 2009 10:51 am

Re: Images do not display in WebHelp in IE

Postby LTinker68 on Wed Feb 04, 2009 2:06 pm

Where are you viewing the help -- on your local machine or on a web server/networked drive? If you're viewing it locally, then you need to enable the MOTW option in the skin. If you're viewing it on a web server or networked drive, then you need to have MOTW disabled.

The MOTW feature is because of security issues that exist in IE but not in Firefox, which is why you can view it in Firefox, regardless of what MOTW is set to.
Image

Lisa
Eagles may soar, but weasels aren't sucked into jet engines.
Warning! Loose nut behind the keyboard.
LTinker68
Master Propellus Maximus
 
Posts: 7245
Joined: Thu Feb 16, 2006 9:38 pm

Re: Images do not display in WebHelp in IE

Postby ginawriter1 on Thu Feb 05, 2009 9:49 am

Thanks for the info. I clicked on Mark of the Web in the target and built the help and it did not work. I am still not seeing images when WebHelp displays in IE.

Plus, my links to pdf files (for the release notes and printable guides) do not work -- as Flare's help warns.

I do not have to "allow blocked content" in IE, but that was never a serious problem.

Thanks again for the idea, please send more!

Gina King
ginawriter1
Jr. Propeller Head
 
Posts: 2
Joined: Tue Feb 03, 2009 10:51 am

Re: Images do not display in WebHelp in IE

Postby RamonS on Thu Feb 05, 2009 10:53 am

When in IE, look at the page source of the content frame and locate the place where the image file is referenced (in the <img> tag). Doe the src parametre point to the correct location? Can you point IE to exactly that location and see the image? Which version of IE is it (IE6 being even more broken than IE7)?
If none of that works, the only other advice I have is not to use IE....and that for more than just this reason.
RamonS
Senior Propellus Maximus
 
Posts: 4291
Joined: Thu Feb 02, 2006 9:29 am
Location: The Electric City

Re: Images do not display in WebHelp in IE

Postby LTinker68 on Thu Feb 05, 2009 1:02 pm

What file types are you using? Transparent PNGs do not display in IE6. Or else they display without transparency. Can't remember which.
Image

Lisa
Eagles may soar, but weasels aren't sucked into jet engines.
Warning! Loose nut behind the keyboard.
LTinker68
Master Propellus Maximus
 
Posts: 7245
Joined: Thu Feb 16, 2006 9:38 pm

Re: Images do not display in WebHelp in IE

Postby RussGuill on Thu Feb 05, 2009 1:21 pm

We had this issue crop up a couple months back. For some reason we just re-saved the image files and they magically started showing up in WebHelp. Still to this day don't understand why it worked, but it did.
RussGuill
Propeller Head
 
Posts: 44
Joined: Fri Feb 03, 2006 10:11 am
Location: Lincoln, NE

Re: Images do not display in WebHelp in IE

Postby Dave Lee on Fri Feb 06, 2009 3:14 am

I've seen something like this before, in that case images were accidentally saved with the wrong filename extensions.

For example, when I save a file in my image editor I could type in the filename image.gif, but I could accidentally have JPEG selected as the format. I would end up with a JPEG image that has a .gif file extension.

Firefox will detect this isn't actually a GIF file and display the image, but IE does not show the image - it will just display a missing link box.

Most image editors will also open the image without warning you anything is wrong with the filename, so the problem may go completely unnoticed.
Dave Lee
Master Propellus Maximus
 
Posts: 5846
Joined: Mon Mar 05, 2007 8:33 am
Location: UK

Re: Images do not display in WebHelp in IE

Postby RamonS on Fri Feb 06, 2009 5:21 am

This is why most image files have headers that explicitly state what the content is (the EXIF headers in JPEGs are really nice). The file extension ought to be entirely irrelevant. As I mentioned before, don't use IE, but use a real browser.
RamonS
Senior Propellus Maximus
 
Posts: 4291
Joined: Thu Feb 02, 2006 9:29 am
Location: The Electric City

Re: Images do not display in WebHelp in IE

Postby Richard Ferrell on Fri Feb 06, 2009 9:46 am

This normally occurs with PNG's and IE, If you resave the images as a different type GIF, JPEG then IE should see them
Richard Ferrell

Certified Madcap Trainer
Image
Richard Ferrell
Propellus Maximus
 
Posts: 837
Joined: Mon May 01, 2006 10:11 am
Location: Inside California


Return to Web-based Outputs

Who is online

Users browsing this forum: No registered users and 6 guests

cron