Cannot run macro in global template

Postby karanclubware on Wed Mar 04, 2020 2:43 pm

Hi all,

My company uses Doc-To-Help 2013 to create help file (.chm) for our software since years ago. I recently started using it as I have to update the Manual and Release Notes for the software regularly. Since last week, the build is failing with the following error message and I am unable to proceed. I have tried multiple suggestions from the web search but same result. The last option would be to re-install Doc-To-Help but that is a bit risky as the person who set it up has left the company and I am not familiar with Doc-To-Help.

I have ensured the and files are copied from the C:\Program Files (x86)\ComponentOne\DocToHelp\Templates\Startup folder to my C:\Users\{user}\AppData\Roaming\Microsoft\Word\STARTUP folder.
I have ensured he macros are enabled in Word in the Trust Center as well.

Error message:

ComponentOne Doc-To-Help
Cannot run macro in global template Make sure that is checked in the list of global templates in Word, dialog Templates and Add-ins.

I really want to avoid re-installing the software. Is there another way I can fix this issue? Thanks.
Jr. Propeller Head
Posts: 1
Joined: Mon Mar 02, 2020 8:48 pm

Re: Cannot run macro in global template

Postby SKamprowski on Mon Mar 09, 2020 7:11 am


since D2H Version 2013 is a rather old Version, I only have "suggestions", no solution:
1. Make sure that there are no older and on your machine.
2. Try it with the original template that were delivered by C1 for your D2H Version.

And be aware that you cannot re-activate D2H 2013!
Kind regards,
Sabine Kamprowski
DocToHelp MVP (by ComponentOne)
Sr. Propeller Head
Posts: 274
Joined: Fri Feb 13, 2015 8:25 am
Location: Germany

Return to Doc-To-Help General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest